Plugins · image-carousel · data as of 2026-11-04
Is Image Carousel safe? Known vulnerabilities and latest version
- Latest version
- 1.0.0.43
- Last updated
- 2026-09-02
- Active installs
- 1,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
Image Carousel Wordpress plugin that lets you create a beautiful responsive image carousel — by GhozyLab
What to do
- Update to the latest version (1.0.0.43). Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get image-carousel --field=version shows what you run; wp plugin update image-carousel updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2025-68074 · published 2026-06-26
Cross-site scripting (XSS) in Image Carousel (1.0.0.41 and older)
- Affected
- 1.0.0.41 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Contributor Cross Site Scripting (XSS) in Image Carousel <= 1.0.0.41 versions.
Recent activity
- 2026-09-02 — latest release on wordpress.org (1.0.0.43).
- 2026-06-26 — Cross-site scripting (XSS) disclosed (CVE-2025-68074), fix version not stated.
Get an email when Image Carousel has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Image Carousel (image-carousel) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by GhozyLab (4 tracked)
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/image-carousel (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/image-carousel"><img src="https://laskyr.com/plugins/image-carousel/badge.svg" alt="Image Carousel vulnerability status"></a>