Skip to content
Laskyr

Plugins · igms-direct-booking · data as of 2026-11-04

Is iGMS Direct Booking safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0)

As of 2026-11-04. 2 issues are on record for older versions; version 2.0 or newer fixes all of them that state a fix.

Latest version
2.0
Last updated
2026-09-12
Active installs
100+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

iGMS Direct Booking Widget allows your guests to make direct reservations with you right via your website. — by igms

What to do

  1. Update to the latest version (2.0). Anything older than 2.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get igms-direct-booking --field=version shows what you run; wp plugin update igms-direct-booking updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-88825 · published 2026-09-18

Cross-site scripting (XSS) in iGMS Direct Booking (older than 2.0)

Affected
older than 2.0
Fixed in
2.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The iGMS Direct Booking WordPress plugin before 2.0 does not authorise or escape its widget appearance settings, allowing unauthenticated users to store arbitrary web scripts that execute in the context of an administrator viewing the iGMS Direct Booking WordPress plugin before 2.0 settings, and in the browser of any visitor to a page displaying the booking widget.

NVD CVE-2026-88825WPScan advisory

medium 5.3 CVE-2026-39652 · published 2026-04-08

Missing authorization check in iGMS Direct Booking (1.3 and older)

Affected
1.3 and older
Fixed in
2.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in igms iGMS Direct Booking igms-direct-booking allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects iGMS Direct Booking: from n/a through <= 1.3.

NVD CVE-2026-39652Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
iGMS Direct Booking vulnerability status badge
<a href="https://laskyr.com/plugins/igms-direct-booking"><img src="https://laskyr.com/plugins/igms-direct-booking/badge.svg" alt="iGMS Direct Booking vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit