Plugins · idx-broker-platinum · data as of 2026-11-04
Is IMPress for IDX Broker safe? Known vulnerabilities and latest version
- Latest version
- 3.3.1
- Last updated
- 2026-09-10
- Active installs
- 7,000+
- Known issues on record
- 7
- Unpatched in latest
- 1
- Tested up to WP
- 7.0.8 · PHP 7.1.8+
IMPress for IDX Broker is now the IMPress family of plugins all-in-one. IMPress Listings and IMPress Agents have been consolidated with this already p … — by IDX Broker
What to do
- There is no fixed version yet. If you can live without IMPress for IDX Broker for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get idx-broker-platinum --field=version shows what you run; wp plugin update idx-broker-platinum updates it.
Check your version
Known vulnerabilities
7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 affects latest 3.3.1 CVE-2026-54869 · published 2026-10-13
Stored cross-site scripting (XSS) in IMPress for IDX Broker (3.3.1 and older)
- Affected
- 3.3.1 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in IDX Broker IMPress for IDX Broker idx-broker-platinum allows Stored XSS.This issue affects IMPress for IDX Broker: from n/a through 3.3.1.
medium 6.5 CVE-2026-81787 · published 2026-09-10
Authentication bypass in IMPress for IDX Broker (3.3.0 and older)
- Affected
- 3.3.0 and older
- Fixed in
- 3.3.1 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Broken Authentication in IMPress for IDX Broker <= 3.3.0 versions.
medium 6.3 CVE-2026-81788 · published 2026-09-10
Missing authorization check in IMPress for IDX Broker (3.3.0 and older)
- Affected
- 3.3.0 and older
- Fixed in
- 3.3.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Subscriber Broken Access Control in IMPress for IDX Broker <= 3.3.0 versions.
medium 6.5 CVE-2025-31556 · published 2025-03-31
Stored cross-site scripting (XSS) in IMPress for IDX Broker (3.2.3 and older)
- Affected
- 3.2.3 and older
- Fixed in
- 3.2.4
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in IDX Broker IMPress for IDX Broker idx-broker-platinum allows Stored XSS.This issue affects IMPress for IDX Broker: from n/a through <= 3.2.3.
medium 5.4 CVE-2024-44047 · published 2024-09-17
Stored cross-site scripting (XSS) in IMPress for IDX Broker (3.2.2 and older)
- Affected
- 3.2.2 and older
- Fixed in
- 3.2.3
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in IDX Broker IMPress for IDX Broker idx-broker-platinum allows Stored XSS.This issue affects IMPress for IDX Broker: from n/a through <= 3.2.2.
medium 6.5 CVE-2020-9514 · published 2020-04-07
Missing authorization check in IMPress for IDX Broker (older than 2.6.2)
- Affected
- older than 2.6.2
- Fixed in
- 2.6.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- advisory text · score by NVD
Details from the advisory
An issue was discovered in the IMPress for IDX Broker plugin before 2.6.2 for WordPress. wrappers.php allows a logged-in user (with the Subscriber role) to permanently delete arbitrary posts and pages, create new posts with arbitrary subjects, and modify the subjects of existing posts and pages (via create_dynamic_page and delete_dynamic_page).
medium 5.4 CVE-2020-11512 · published 2020-04-07
Stored cross-site scripting (XSS) in IMPress for IDX Broker (older than 2.6.2)
- Affected
- older than 2.6.2
- Fixed in
- 2.6.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
Stored XSS in the IMPress for IDX Broker WordPress plugin before 2.6.2 allows authenticated attackers with minimal (subscriber-level) permissions to save arbitrary JavaScript in the plugin's settings panel via the idx_update_recaptcha_key AJAX action and a crafted idx_recaptcha_site_key parameter, which would then be executed in the browser of any administrator visiting the panel. This could be used to create new administrator-level accounts.
Recent activity
- 2026-09-10 — latest release on wordpress.org (3.3.1).
- 2026-10-13 — Stored cross-site scripting (XSS) disclosed (CVE-2026-54869), no fix listed yet.
- 2026-09-10 — Authentication bypass disclosed (CVE-2026-81787), fixed in 3.3.1.
- 2026-09-10 — Missing authorization check disclosed (CVE-2026-81788), fixed in 3.3.1.
Get an email when IMPress for IDX Broker has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for IMPress for IDX Broker (idx-broker-platinum) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (4) · Missing authorization (2) · Authentication bypass (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/idx-broker-platinum (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/idx-broker-platinum"><img src="https://laskyr.com/plugins/idx-broker-platinum/badge.svg" alt="IMPress for IDX Broker vulnerability status"></a>