Plugins · ics-calendar · data as of 2026-11-04
Is ICS Calendar safe? Known vulnerabilities and latest version
- Latest version
- 12.3.0
- Last updated
- 2026-10-29
- Active installs
- 10,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.1+
Add the calendar you already use to any WordPress site! Google Calendar, Microsoft 365, iCloud and more… no API keys or complicated setup required. — by Room 34 Creative Services, LLC
What to do
- Update to the latest version (12.3.0). Anything older than 12.1.1.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get ics-calendar --field=version shows what you run; wp plugin update ics-calendar updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-59516 · published 2026-07-13
Reflected cross-site scripting (XSS) in ICS Calendar (12.1.1 and older)
- Affected
- 12.1.1 and older
- Fixed in
- 12.1.1.1
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Room 34 Creative Services, LLC ICS Calendar ics-calendar allows Reflected XSS.This issue affects ICS Calendar: from n/a through <= 12.1.1.
medium 6.1 CVE-2026-9838 · published 2026-07-10
Reflected cross-site scripting (XSS) in ICS Calendar (12.0.9 and older)
- Affected
- 12.0.9 and older
- Fixed in
- 12.0.9.2 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The ICS Calendar plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'htmltagtitle' parameter in all versions up to, and including, 12.0.9 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. The vulnerability is reachable via the unauthenticated wp_ajax_nopriv_r34ics_ajax AJAX action, which accepts attacker-controlled js_args values merged over stored shortcode configuration without nonce verification, allowing the htmltagtitle key to bypass the normal shortcode allowlist check.
NVD CVE-2026-9838Wordfence advisoryCode change (fix)Plugin source
high 8.2 CVE-2023-46784 · published 2024-05-17
Path traversal / file read in ICS Calendar (10.12.0.3 and older)
- Affected
- 10.12.0.3 and older
- Fixed in
- 10.12.0.4
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal'), Server-Side Request Forgery (SSRF) vulnerability in Room 34 Creative Services, LLC ICS Calendar ics-calendar allows Absolute Path Traversal, : Server Side Request Forgery.This issue affects ICS Calendar: from n/a through 10.12.0.3.
Recent activity
- 2026-10-29 — latest release on wordpress.org (12.3.0).
- 2026-07-13 — Reflected cross-site scripting (XSS) disclosed (CVE-2026-59516), fixed in 12.1.1.1.
- 2026-07-10 — Reflected cross-site scripting (XSS) disclosed (CVE-2026-9838), fixed in 12.0.9.2.
- 2024-05-17 — Path traversal / file read disclosed (CVE-2023-46784), fixed in 10.12.0.4.
Get an email when ICS Calendar has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for ICS Calendar (ics-calendar) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2) · Path traversal and file read (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/ics-calendar (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/ics-calendar"><img src="https://laskyr.com/plugins/ics-calendar/badge.svg" alt="ICS Calendar vulnerability status"></a>