Skip to content
Laskyr

Plugins · icon-list-block · data as of 2026-11-04

Is Icon List Block safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.9)

As of 2026-11-04. 3 issues are on record for older versions; version 1.2.4 or newer fixes all of them that state a fix.

Latest version
1.2.9
Last updated
2026-10-31
Active installs
4,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Create a list with an icon with this block plugin. — by bPlugins

What to do

  1. Update to the latest version (1.2.9). Anything older than 1.2.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get icon-list-block --field=version shows what you run; wp plugin update icon-list-block updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-32359 · published 2026-03-13

Stored cross-site scripting (XSS) in Icon List Block (1.2.3 and older)

Affected
1.2.3 and older
Fixed in
1.2.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Icon List Block icon-list-block allows Stored XSS.This issue affects Icon List Block: from n/a through <= 1.2.3.

NVD CVE-2026-32359Patchstack advisory

medium 6.4 CVE-2025-12376 · published 2025-11-18

Server-side request forgery (SSRF) in Icon List Block (1.2.1 and older)

Affected
1.2.1 and older
Fixed in
1.2.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Icon List Block – Add Icon-Based Lists with Custom Styles plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 1.2.1 via the fs_api_request function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services. Only valid JSON objects are rendered in the response.

NVD CVE-2025-12376Wordfence advisoryPlugin source

medium 6.5 CVE-2025-26937 · published 2025-02-25

Stored cross-site scripting (XSS) in Icon List Block (1.1.3 and older)

Affected
1.1.3 and older
Fixed in
1.1.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Icon List Block icon-list-block allows Stored XSS.This issue affects Icon List Block: from n/a through <= 1.1.3.

NVD CVE-2025-26937Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Icon List Block vulnerability status badge
<a href="https://laskyr.com/plugins/icon-list-block"><img src="https://laskyr.com/plugins/icon-list-block/badge.svg" alt="Icon List Block vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit