Plugins · icegram-mailer · data as of 2026-11-04
Is Icegram Mailer safe? Known vulnerabilities and latest version
- Latest version
- 1.0.15
- Last updated
- 2026-10-26
- Active installs
- 2,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.0+
Fix WordPress & WooCommerce email delivery without complex SMTP setup. Built-in sending service, 200 free emails/month, email logs & 1-click resend. — by Icegram
What to do
- Update to the latest version (1.0.15). Anything older than 1.0.13 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get icegram-mailer --field=version shows what you run; wp plugin update icegram-mailer updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.9 CVE-2026-15951 · published 2026-08-01
SQL injection in Icegram Mailer (1.0.12 and older)
- Affected
- 1.0.12 and older
- Fixed in
- 1.0.13 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Icegram Mailer plugin for WordPress is vulnerable to SQL Injection via the 'fields' parameter in versions up to, and including, 1.0.12. This is due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query in the Icegram_Mailer_Logs_Table::get_logs() function, where each element of the `fields` array received from $_REQUEST['data'] is joined verbatim into the SELECT clause via implode() with no whitelist, escaping, or prepared-statement placeholder. This makes it possible for authenticated attackers, with Administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
NVD CVE-2026-15951Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-10-26 — latest release on wordpress.org (1.0.15).
- 2026-08-01 — SQL injection disclosed (CVE-2026-15951), fixed in 1.0.13.
Get an email when Icegram Mailer has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Icegram Mailer (icegram-mailer) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Icegram (3 tracked)
Types found in this plugin: SQL injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/icegram-mailer (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/icegram-mailer"><img src="https://laskyr.com/plugins/icegram-mailer/badge.svg" alt="Icegram Mailer vulnerability status"></a>