Skip to content
Laskyr

Plugins · ibtana-visual-editor · data as of 2026-11-04

Is Ibtana safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.6.5)

As of 2026-11-04. 8 issues are on record for older versions; version 1.2.6 or newer fixes all of them that state a fix.

Latest version
1.2.6.5
Last updated
2026-08-20
Active installs
10,000+
Known issues on record
8
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.2+

Build your dream WordPress website with Ibtana, a powerful website builder with customizable templates and drag-and-drop elements for customization. — by VW THEMES

What to do

  1. Update to the latest version (1.2.6.5). Anything older than 1.2.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get ibtana-visual-editor --field=version shows what you run; wp plugin update ibtana-visual-editor updates it.

Check your version

Known vulnerabilities

8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-1834 · published 2026-03-31

Stored cross-site scripting (XSS) in Ibtana (1.2.5.7 and older)

Affected
1.2.5.7 and older
Fixed in
1.2.5.8 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Ibtana – WordPress Website Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'ive' shortcode in all versions up to, and including, 1.2.5.7 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-1834Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2025-59581 · published 2025-09-22

Missing authorization check in Ibtana (1.2.5.3 and older)

Affected
1.2.5.3 and older
Fixed in
1.2.5.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in VW THEMES Ibtana ibtana-visual-editor allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Ibtana: from n/a through <= 1.2.5.3.

NVD CVE-2025-59581Patchstack advisory

medium 6.5 CVE-2025-26891 · published 2025-02-25

Stored cross-site scripting (XSS) in Ibtana (1.2.5.9 and older)

Affected
1.2.5.9 and older
Fixed in
1.2.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in VW THEMES Ibtana ibtana-visual-editor allows Stored XSS.This issue affects Ibtana: from n/a through <= 1.2.5.9.

NVD CVE-2025-26891Patchstack advisory

medium 5.3 CVE-2024-37123 · published 2024-11-01

Missing authorization check in Ibtana (1.2.3.3 and older)

Affected
1.2.3.3 and older
Fixed in
1.2.3.4
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in VowelWeb Ibtana allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Ibtana: from n/a through 1.2.3.3.

NVD CVE-2024-37123Patchstack advisory

medium 5.4 CVE-2024-8282 · published 2024-10-02

Stored cross-site scripting (XSS) in Ibtana (1.2.4.4 and older)

Affected
1.2.4.4 and older
Fixed in
1.2.4.5 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Ibtana – WordPress Website Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘align’ attribute within the 'wp:ive/ive-productscarousel' Gutenberg block in all versions up to, and including, 1.2.4.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-8282Wordfence advisoryCode change (fix)wordpress.orgPlugin source

medium 5.3 CVE-2024-5541 · published 2024-06-18

Missing authorization check in Ibtana (1.2.3.3 and older)

Affected
1.2.3.3 and older
Fixed in
1.2.4.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Ibtana – WordPress Website Builder plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'ibtana_visual_editor_register_ajax_json_endpont' function in all versions up to, and including, 1.2.3.3. This makes it possible for unauthenticated attackers to update option values for reCAPTCHA keys on the WordPress site. This can be leveraged to bypass reCAPTCHA on the site. CVE-2024-37123 is likely a duplicate of this issue.

NVD CVE-2024-5541Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2023-6684 · published 2024-01-11

Stored cross-site scripting (XSS) in Ibtana (1.2.2 and older)

Affected
1.2.2 and older
Fixed in
1.2.4.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Ibtana – WordPress Website Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'ive' shortcode in versions up to, and including, 1.2.2 due to insufficient input sanitization and output escaping on 'width' and 'height' user supplied attribute. This makes it possible for authenticated attackers with contributor level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2023-6684Wordfence advisoryCode change (fix)Plugin source

low 3.5 CVE-2021-25014 · published 2022-02-14

Cross-site request forgery (CSRF) in Ibtana (older than 1.1.4.9)

Affected
older than 1.1.4.9
Fixed in
1.1.4.9
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
advisory text · score by NVD
Details from the advisory

The Ibtana WordPress plugin before 1.1.4.9 does not have authorisation and CSRF checks in the ive_save_general_settings AJAX action, allowing any authenticated users, such as subscriber to call it and change the plugin's settings which could lead to Stored Cross-Site Scripting issue.

NVD CVE-2021-25014WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Ibtana vulnerability status badge
<a href="https://laskyr.com/plugins/ibtana-visual-editor"><img src="https://laskyr.com/plugins/ibtana-visual-editor/badge.svg" alt="Ibtana vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit