Skip to content
Laskyr

Plugins · ibtana-ecommerce-product-addons · data as of 2026-11-04

Is Ibtana safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (0.4.7.9)

As of 2026-11-04. 2 issues are on record for older versions; version 0.4.7.8 or newer fixes all of them that state a fix.

Latest version
0.4.7.9
Last updated
2026-08-12
Active installs
5,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.2+

Ibtana - Ecommerce Product Addons, you get to explore so many options for editing the product page by simple drag and drop functionality. — by VW THEMES

What to do

  1. Update to the latest version (0.4.7.9). Anything older than 0.4.7.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get ibtana-ecommerce-product-addons --field=version shows what you run; wp plugin update ibtana-ecommerce-product-addons updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-1984 · published 2026-09-19

Missing authorization check in Ibtana (0.4.7.7 and older)

Affected
0.4.7.7 and older
Fixed in
0.4.7.8 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Ibtana – Ecommerce Product Addons plugin for WordPress is vulnerable to unauthorized post meta modification due to a missing capability check on the 'iepa_use_gt_editor' AJAX action in all versions up to, and including, 0.4.7.7. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update or delete arbitrary post meta entries via the 'iepa_builder' meta key.

NVD CVE-2026-1984Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2025-58786 · published 2025-09-05

Cross-site scripting (XSS) in Ibtana (0.4.7.6 and older)

Affected
0.4.7.6 and older
Fixed in
0.4.7.7 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in VW THEMES Ibtana – Ecommerce Product Addons ibtana-ecommerce-product-addons allows DOM-Based XSS.This issue affects Ibtana – Ecommerce Product Addons: from n/a through <= 0.4.7.6.

NVD CVE-2025-58786Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Ibtana vulnerability status badge
<a href="https://laskyr.com/plugins/ibtana-ecommerce-product-addons"><img src="https://laskyr.com/plugins/ibtana-ecommerce-product-addons/badge.svg" alt="Ibtana vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit