Skip to content
Laskyr

Plugins · hurrytimer · data as of 2026-11-04

Is HurryTimer safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.19.0)

As of 2026-11-04. 5 issues are on record for older versions; version 2.14.3 or newer fixes all of them that state a fix.

Latest version
2.19.0
Last updated
2026-10-28
Active installs
20,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

Create unlimited urgency and scarcity countdown timers for WordPress and WooCommerce to boost conversions and sales instantly. — by Nabil Lemsieh

What to do

  1. Update to the latest version (2.19.0). Anything older than 2.14.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get hurrytimer --field=version shows what you run; wp plugin update hurrytimer updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.9 CVE-2026-24392 · published 2026-02-19

Stored cross-site scripting (XSS) in HurryTimer (2.14.2 and older)

Affected
2.14.2 and older
Fixed in
2.14.3
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Nabil Lemsieh HurryTimer hurrytimer allows Stored XSS.This issue affects HurryTimer: from n/a through <= 2.14.2.

NVD CVE-2026-24392Patchstack advisory

medium 5.3 CVE-2025-53255 · published 2025-06-27

Missing authorization check in HurryTimer (2.13.1 and older)

Affected
2.13.1 and older
Fixed in
2.14.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Nabil Lemsieh HurryTimer hurrytimer allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects HurryTimer: from n/a through <= 2.13.1.

NVD CVE-2025-53255Patchstack advisory

medium 5.4 CVE-2024-13735 · published 2025-02-14

Stored cross-site scripting (XSS) in HurryTimer (2.11.2 and older)

Affected
2.11.2 and older
Fixed in
2.12.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The HurryTimer – An Scarcity and Urgency Countdown Timer for WordPress & WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 2.11.2 due to insufficient input sanitization and output escaping of a campaign name. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-13735Wordfence advisoryCode change (fix)wordpress.orgdocs.hurrytimer.com

medium 4.3 CVE-2024-8667 · published 2024-10-24

Missing authorization check in HurryTimer (2.10.0 and older)

Affected
2.10.0 and older
Fixed in
2.11.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The HurryTimer – An Scarcity and Urgency Countdown Timer for WordPress & WooCommerce plugin for WordPress is vulnerable to unauthorized post publication due to a missing capability check on the activateCampaign() function in all versions up to, and including, 2.10.0. This makes it possible for authenticated attackers, with contributor-level access and above, to publish arbitrary posts like ones they have submitted for review, or a site administrator has in draft.

NVD CVE-2024-8667Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2024-32556 · published 2024-04-18

Stored cross-site scripting (XSS) in HurryTimer (2.9.2 and older)

Affected
2.9.2 and older
Fixed in
2.10.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Nabil Lemsieh HurryTimer allows Stored XSS.This issue affects HurryTimer: from n/a through 2.9.2.

NVD CVE-2024-32556Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
HurryTimer vulnerability status badge
<a href="https://laskyr.com/plugins/hurrytimer"><img src="https://laskyr.com/plugins/hurrytimer/badge.svg" alt="HurryTimer vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit