Plugins · html5-audio-player · data as of 2026-11-04
Is HTML5 Audio Player safe? Known vulnerabilities and latest version
- Latest version
- 2.10.1
- Last updated
- 2026-11-01
- Active installs
- 10,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.1+
Maximize your WordPress site's potential with our versatile HTML5 Audio Player plugin. Seamlessly play .mp3, .wav, .ogg, and more audio files. — by bPlugins
What to do
- Update to the latest version (2.10.1). Anything older than 2.9.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get html5-audio-player --field=version shows what you run; wp plugin update html5-audio-player updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-62039 · published 2026-10-09
Stored cross-site scripting (XSS) in HTML5 Audio Player (2.8.8 and older)
- Affected
- 2.8.8 and older
- Fixed in
- 2.9.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Html5 Audio Player html5-audio-player allows Stored XSS.This issue affects Html5 Audio Player: from n/a through 2.8.8.
high 7.2 CVE-2025-13999 · published 2025-12-19
Server-side request forgery (SSRF) in HTML5 Audio Player (2.4.0 to 2.5.1)
- Affected
- 2.4.0 to 2.5.1
- Fixed in
- 2.5.2 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The HTML5 Audio Player – The Ultimate No-Code Podcast, MP3 & Audio Player plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions from 2.4.0 up to, and including, 2.5.1 via the getIcyMetadata() function. This makes it possible for unauthenticated attackers to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.
medium 6.5 CVE-2025-39524 · published 2025-04-16
Stored cross-site scripting (XSS) in HTML5 Audio Player (2.2.28 and older)
- Affected
- 2.2.28 and older
- Fixed in
- 2.3.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in bPlugins Html5 Audio Player html5-audio-player allows Stored XSS.This issue affects Html5 Audio Player: from n/a through <= 2.2.28.
medium 5.4 CVE-2024-37445 · published 2024-07-22
Stored cross-site scripting (XSS) in HTML5 Audio Player (2.2.23 and older)
- Affected
- 2.2.23 and older
- Fixed in
- 2.2.24
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in bPlugins Html5 Audio Player allows Stored XSS.This issue affects Html5 Audio Player: from n/a through 2.2.23.
medium 6.4 CVE-2024-4398 · published 2024-05-14
Stored cross-site scripting (XSS) in HTML5 Audio Player (2.2.19 and older)
- Affected
- 2.2.19 and older
- Fixed in
- 2.2.24 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The HTML5 Audio Player- Best WordPress Audio Player Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's widgets in all versions up to, and including, 2.2.19 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
medium 5.4 CVE-2023-0170 · published 2023-02-06
Stored cross-site scripting (XSS) in HTML5 Audio Player (older than 2.1.12)
- Affected
- older than 2.1.12
- Fixed in
- 2.1.12
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Html5 Audio Player WordPress plugin before 2.1.12 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Recent activity
- 2026-11-01 — latest release on wordpress.org (2.10.1).
- 2026-10-09 — Stored cross-site scripting (XSS) disclosed (CVE-2026-62039), fixed in 2.9.0.
- 2025-12-19 — Server-side request forgery (SSRF) disclosed (CVE-2025-13999), fixed in 2.5.2.
- 2025-04-16 — Stored cross-site scripting (XSS) disclosed (CVE-2025-39524), fixed in 2.3.0.
Get an email when HTML5 Audio Player has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for HTML5 Audio Player (html5-audio-player) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by bPlugins (36 tracked)
Types found in this plugin: Cross-site scripting (XSS) (5) · Server-side request forgery (SSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/html5-audio-player (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/html5-audio-player"><img src="https://laskyr.com/plugins/html5-audio-player/badge.svg" alt="HTML5 Audio Player vulnerability status"></a>