Skip to content
Laskyr

Plugins · html-forms · data as of 2026-11-04

Is HTML Forms safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.7.1)

As of 2026-11-04. 9 issues are on record for older versions; version 1.6.1 or newer fixes all of them that state a fix.

Latest version
1.7.1
Last updated
2026-09-22
Active installs
10,000+
Known issues on record
9
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.3+

A simpler, faster, and smarter WordPress forms plugin. — by Link Software LLC

What to do

  1. Update to the latest version (1.7.1). Anything older than 1.6.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get html-forms --field=version shows what you run; wp plugin update html-forms updates it.

Check your version

Known vulnerabilities

9 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.1 CVE-2025-13861 · published 2025-12-17

Stored cross-site scripting (XSS) in HTML Forms (1.6.0 and older)

Affected
1.6.0 and older
Fixed in
1.6.1 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The HTML Forms – Simple WordPress Forms Plugin for WordPress is vulnerable to Unauthenticated Stored Cross-Site Scripting in all versions up to and including 1.6.0 due to insufficient sanitization of fabricated file upload field metadata before displaying it in the WordPress admin dashboard. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute whenever an administrator accesses the form submissions page.

NVD CVE-2025-13861Wordfence advisoryCode change (fix)Plugin source

medium 4.4 CVE-2025-12125 · published 2025-11-08

Stored cross-site scripting (XSS) in HTML Forms (1.5.5 and older)

Affected
1.5.5 and older
Fixed in
1.5.6 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The HTML Forms – Simple WordPress Forms Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 1.5.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2025-12125Wordfence advisoryCode change (fix)

medium 5.4 CVE-2025-46236 · published 2025-04-22

Stored cross-site scripting (XSS) in HTML Forms (1.5.2 and older)

Affected
1.5.2 and older
Fixed in
1.5.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Link Software LLC HTML Forms html-forms allows Stored XSS.This issue affects HTML Forms: from n/a through <= 1.5.2.

NVD CVE-2025-46236Patchstack advisory

high 7.1 CVE-2025-31080 · published 2025-04-01

Stored cross-site scripting (XSS) in HTML Forms (1.5.1 and older)

Affected
1.5.1 and older
Fixed in
1.5.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Link Software LLC HTML Forms html-forms allows Stored XSS.This issue affects HTML Forms: from n/a through <= 1.5.1.

NVD CVE-2025-31080Patchstack advisory

high 7.1 CVE-2024-56060 · published 2025-01-02

Reflected cross-site scripting (XSS) in HTML Forms (1.4.1 and older)

Affected
1.4.1 and older
Fixed in
1.4.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Link Software LLC HTML Forms html-forms allows Reflected XSS.This issue affects HTML Forms: from n/a through <= 1.4.1.

NVD CVE-2024-56060Patchstack advisory

medium 6.5 CVE-2024-6412 · published 2024-07-31

Cross-site request forgery (CSRF) in HTML Forms (older than 1.3.34)

Affected
older than 1.3.34
Fixed in
1.3.34
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The HTML Forms WordPress plugin before 1.3.34 does not have CSRF checks in some places, which could allow attackers to make logged in users perform unwanted actions via CSRF attacks

NVD CVE-2024-6412WPScan advisory

medium 4.8 CVE-2024-6243 · published 2024-07-22

Stored cross-site scripting (XSS) in HTML Forms (older than 1.3.33)

Affected
older than 1.3.33
Fixed in
1.3.33
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The HTML Forms WordPress plugin before 1.3.33 does not sanitize and escape the form message inputs, allowing high-privilege users, such as administrators, to perform Stored Cross-Site Scripting (XSS) attacks even when the unfiltered_html capability is disabled.

NVD CVE-2024-6243WPScan advisory

medium 4.8 CVE-2023-50836 · published 2023-12-28

Stored cross-site scripting (XSS) in HTML Forms (1.3.28 and older)

Affected
1.3.28 and older
Fixed in
1.3.29 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ibericode HTML Forms allows Stored XSS.This issue affects HTML Forms: from n/a through 1.3.28.

NVD CVE-2023-50836Patchstack advisory

high 7.2 CVE-2022-3689 · published 2022-11-28

SQL injection in HTML Forms (older than 1.3.25)

Affected
older than 1.3.25
Fixed in
1.3.25
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The HTML Forms WordPress plugin before 1.3.25 does not properly properly escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by high privilege users

NVD CVE-2022-3689WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
HTML Forms vulnerability status badge
<a href="https://laskyr.com/plugins/html-forms"><img src="https://laskyr.com/plugins/html-forms/badge.svg" alt="HTML Forms vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit