Plugins · ht-slider-for-elementor · data as of 2026-11-04
Is HT Slider For Elementor safe? Known vulnerabilities and latest version
- Latest version
- 1.7.11
- Last updated
- 2026-10-28
- Active installs
- 20,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
The HT Slider is an Elementor slider plugin that enables you to add advanced sliders to your WordPress website. — by HT Plugins
What to do
- Update to the latest version (1.7.11). Anything older than 1.7.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get ht-slider-for-elementor --field=version shows what you run; wp plugin update ht-slider-for-elementor updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2025-14278 · published 2025-12-13
Stored cross-site scripting (XSS) in HT Slider For Elementor (1.7.4 and older)
- Affected
- 1.7.4 and older
- Fixed in
- 1.7.5 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The HT Slider for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'slide_title' parameter in all versions up to, and including, 1.7.4 due to insufficient input sanitization and output escaping in JavaScript. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2025-14278Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2025-53199 · published 2025-06-27
Cross-site scripting (XSS) in HT Slider For Elementor (1.6.5 and older)
- Affected
- 1.6.5 and older
- Fixed in
- 1.6.6
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in HT Plugins HT Slider For Elementor ht-slider-for-elementor allows DOM-Based XSS.This issue affects HT Slider For Elementor: from n/a through <= 1.6.5.
medium 4.3 CVE-2023-0495 · published 2023-03-27
Cross-site request forgery (CSRF) in HT Slider For Elementor (older than 1.4.0)
- Affected
- older than 1.4.0
- Fixed in
- 1.4.0
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The HT Slider For Elementor WordPress plugin before 1.4.0 does not have CSRF check when activating plugins, which could allow attackers to make logged in admins activate arbitrary plugins present on the blog via a CSRF attack
Recent activity
- 2026-10-28 — latest release on wordpress.org (1.7.11).
- 2025-12-13 — Stored cross-site scripting (XSS) disclosed (CVE-2025-14278), fixed in 1.7.5.
- 2025-06-27 — Cross-site scripting (XSS) disclosed (CVE-2025-53199), fixed in 1.6.6.
- 2023-03-27 — Cross-site request forgery (CSRF) disclosed (CVE-2023-0495), fixed in 1.4.0.
Get an email when HT Slider For Elementor has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for HT Slider For Elementor (ht-slider-for-elementor) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by HT Plugins (6 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/ht-slider-for-elementor (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/ht-slider-for-elementor"><img src="https://laskyr.com/plugins/ht-slider-for-elementor/badge.svg" alt="HT Slider For Elementor vulnerability status"></a>