Skip to content
Laskyr

Plugins · hr-management-lite · data as of 2026-11-04

Is HR Management Lite safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.9)

As of 2026-11-04. 2 issues are on record for older versions; version 3.7 or newer fixes all of them that state a fix.

Latest version
3.9
Last updated
2026-09-11
Active installs
200+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4

HR Plugin for WordPress to Manage the HR works and the Projects. — by Weblizar - WordPress Themes & Plugin

What to do

  1. Update to the latest version (3.9). Anything older than 3.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get hr-management-lite --field=version shows what you run; wp plugin update hr-management-lite updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2025-69022 · published 2025-12-30

Missing authorization check in HR Management Lite (3.6 and older)

Affected
3.6 and older
Fixed in
3.7 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Weblizar - WordPress Themes & Plugin HR Management Lite hr-management-lite allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects HR Management Lite: from n/a through <= 3.6.

NVD CVE-2025-69022Patchstack advisory

medium 4.3 CVE-2025-29005 · published 2025-06-06

Cross-site request forgery (CSRF) in HR Management Lite (3.6 and older)

Affected
3.6 and older
Fixed in
3.7 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Weblizar - WordPress Themes & Plugin HR Management Lite hr-management-lite allows Cross Site Request Forgery.This issue affects HR Management Lite: from n/a through <= 3.6.

NVD CVE-2025-29005Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
HR Management Lite vulnerability status badge
<a href="https://laskyr.com/plugins/hr-management-lite"><img src="https://laskyr.com/plugins/hr-management-lite/badge.svg" alt="HR Management Lite vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit