Skip to content
Laskyr

Plugins · hotelrunner · data as of 2026-11-04

Is HotelRunner Booking Widget safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.7)

As of 2026-11-04. 2 issues are on record for older versions; version 1.7 or newer fixes all of them that state a fix.

Latest version
1.7
Last updated
2026-06-24
Active installs
100+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
5.6.23 · PHP 5.2.4+

This plugin adds HotelRunner Booking Widget to website — by integrationshotelrunner

What to do

  1. Update to the latest version (1.7). Anything older than 1.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get hotelrunner --field=version shows what you run; wp plugin update hotelrunner updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 1 record(s) do not state which versions are affected.

medium 6.4 CVE-2025-13135 · published 2025-11-21

Stored cross-site scripting (XSS) in HotelRunner Booking Widget (5.2.4 and older)

Affected
5.2.4 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence

Note: the source's version range goes past the newest HotelRunner Booking Widget release on wordpress.org (1.7), so it probably describes a paid edition with its own version numbers, or contains a typo. We do not use it to judge your version.

Details from the advisory

The HotelRunner Booking Widget plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'hotelrunner' shortcode in all versions up to, and including, 5.2.4 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-13135Wordfence advisorywordpress.org

high 7.1 CVE-2025-60168 · published 2025-10-22

Cross-site request forgery (CSRF) in HotelRunner Booking Widget (1.6 and older)

Affected
1.6 and older
Fixed in
1.7 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in integrationshotelrunner HotelRunner Booking Widget hotelrunner allows Stored XSS.This issue affects HotelRunner Booking Widget: from n/a through <= 1.6.

NVD CVE-2025-60168Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
HotelRunner Booking Widget vulnerability status badge
<a href="https://laskyr.com/plugins/hotelrunner"><img src="https://laskyr.com/plugins/hotelrunner/badge.svg" alt="HotelRunner Booking Widget vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit