Skip to content
Laskyr

Plugins · hostinger-reach · data as of 2026-11-01

Is Hostinger Reach safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.8.7)

As of 2026-11-01. 2 issues are on record for older versions; version 1.8.3 or newer fixes all of them that state a fix.

Latest version
1.8.7
Last updated
2026-10-14
Active installs
1+ million
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.1+

Launch and grow your email marketing effortlessly with Hostinger Reach. Collect contacts, sync subscribers, and send emails – all in one, AI powered. — by Hostinger

What to do

  1. Update to the latest version (1.8.7). Anything older than 1.8.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get hostinger-reach --field=version shows what you run; wp plugin update hostinger-reach updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.8 CVE-2026-87777 · published 2026-09-30

Cross-site scripting (XSS) in Hostinger Reach (1.0.6 up to (not including) 1.8.3)

Affected
1.0.6 up to (not including) 1.8.3
Fixed in
1.8.3
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Hostinger Reach WordPress plugin before 1.8.3 does not sanitize and escape a widget setting before outputting it in the editor preview, allowing users with contributor-level access and above to inject arbitrary web scripts that will execute in the session of a higher-privileged user who opens the affected content in the editor.

NVD CVE-2026-87777WPScan advisory

medium 5.3 CVE-2026-2515 · published 2026-05-13

Missing authorization check in Hostinger Reach (1.3.8 and older)

Affected
1.3.8 and older
Fixed in
1.3.9 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Hostinger Reach – AI-Powered Email Marketing for WordPress plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'handle_ajax_action' function in all versions up to, and including, 1.3.8. This makes it possible for authenticated attackers, with Subscriber-level access and above, to use the 'hostinger_reach_connection_notice_action' action to update the API key value stored in the database. This vulnerability can only be exploited when the plugin is not connected to a site and no API key value exists in the database.

NVD CVE-2026-2515Wordfence advisoryCode change (fix)Plugin source

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Hostinger Reach vulnerability status badge
<a href="https://laskyr.com/plugins/hostinger-reach"><img src="https://laskyr.com/plugins/hostinger-reach/badge.svg" alt="Hostinger Reach vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit