Plugins · hostinger · data as of 2026-11-01
Is Hostinger Tools safe? Known vulnerabilities and latest version
- Latest version
- 3.0.80
- Last updated
- 2026-10-21
- Active installs
- 3+ million
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.1+
Simplified WordPress management. Manage site info, maintenance, security, & redirects. — by Hostinger
What to do
- Update to the latest version (3.0.80). Anything older than 1.9.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get hostinger --field=version shows what you run; wp plugin update hostinger updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2023-6751 · published 2024-01-11
Missing authorization check in Hostinger Tools (1.9.7 and older)
- Affected
- 1.9.7 and older
- Fixed in
- 1.9.8 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Hostinger plugin for WordPress is vulnerable to unauthorized plugin settings update due to a missing capability check on the function publish_website in all versions up to, and including, 1.9.7. This makes it possible for unauthenticated attackers to enable and disable maintenance mode.
Recent activity
- 2026-10-21 — latest release on wordpress.org (3.0.80).
- 2024-01-11 — Missing authorization check disclosed (CVE-2023-6751), fixed in 1.9.8.
Get an email when Hostinger Tools has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Hostinger Tools (hostinger) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/hostinger (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/hostinger"><img src="https://laskyr.com/plugins/hostinger/badge.svg" alt="Hostinger Tools vulnerability status"></a>