Skip to content
Laskyr

Plugins · host-webfonts-local · data as of 2026-11-01

Is OMGF safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (6.4.0)

As of 2026-11-01. 3 issues are on record for older versions; version 6.3.11 or newer fixes all of them that state a fix.

Latest version
6.4.0
Last updated
2026-10-30
Active installs
300,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.3+

The original Google Fonts self-hosting plugin. Automagically caches your fonts locally — no configuration (or brains) required! — by Daan van den Bergh

What to do

  1. Update to the latest version (6.4.0). Anything older than 6.3.11 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get host-webfonts-local --field=version shows what you run; wp plugin update host-webfonts-local updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-89417 · published 2026-10-07

Stored cross-site scripting (XSS) in OMGF (6.3.10 and older)

Affected
6.3.10 and older
Fixed in
6.3.11 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The OMGF | GDPR/DSGVO Compliant, Faster Google Fonts. Easy. plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 's' Search Parameter via comments-atom Feed in all versions up to, and including, 6.3.10 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Successful exploitation requires that the front-end server serves the retained .tmp file without a Content-Type or X-Content-Type-Options header, enabling MIME-sniffing browsers such as Chromium to execute the injected script — a condition present by default on many Apache and nginx/php-fpm deployments.

NVD CVE-2026-89417Wordfence advisoryCode change (fix)Plugin source

high 7.5 CVE-2026-91828 · published 2026-10-02

Denial of service in OMGF (older than 6.3.11)

Affected
older than 6.3.11
Fixed in
6.3.11
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The OMGF | GDPR/DSGVO Compliant, Faster Google Fonts. Easy. WordPress plugin before 6.3.11 does not require authentication or a valid nonce on an action that issues a slow server-side loopback request, allowing unauthenticated attackers to exhaust the site's PHP worker pool and make the entire site unavailable.

NVD CVE-2026-91828WPScan advisory

medium 5.4 CVE-2023-6600 · published 2024-01-03

Stored cross-site scripting (XSS) in OMGF (5.7.9 and older)

Affected
5.7.9 and older
Fixed in
5.7.10 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The OMGF | GDPR/DSGVO Compliant, Faster Google Fonts. Easy. plugin for WordPress is vulnerable to unauthorized modification of data and Stored Cross-Site Scripting due to a missing capability check on the update_settings() function hooked via admin_init in all versions up to, and including, 5.7.9. This makes it possible for unauthenticated attackers to update the plugin's settings which can be used to inject Cross-Site Scripting payloads and delete entire directories. PLease note there were several attempted patched, and we consider 5.7.10 to be the most sufficiently patched.

NVD CVE-2023-6600Wordfence advisoryCode change (fix)

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
OMGF vulnerability status badge
<a href="https://laskyr.com/plugins/host-webfonts-local"><img src="https://laskyr.com/plugins/host-webfonts-local/badge.svg" alt="OMGF vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit