Plugins · honeypot · data as of 2026-11-01
Is WP Armour safe? Known vulnerabilities and latest version
- Latest version
- 2.4.02
- Last updated
- 2026-09-03
- Active installs
- 400,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
Fastest growing Anti Spam plugin. No API calls, subscriptions, captcha or puzzle. Full GDPR complaint. For comments, contact form, login, registration — by Dnesscarkey
What to do
- Update to the latest version (2.4.02). Anything older than 2.1.14 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get honeypot --field=version shows what you run; wp plugin update honeypot updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2024-29091 · published 2024-03-19
Reflected cross-site scripting (XSS) in WP Armour (2.1.13 and older)
- Affected
- 2.1.13 and older
- Fixed in
- 2.1.14
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Dnesscarkey WP Armour – Honeypot Anti Spam allows Reflected XSS.This issue affects WP Armour – Honeypot Anti Spam: from n/a through 2.1.13.
Recent activity
- 2026-09-03 — latest release on wordpress.org (2.4.02).
- 2024-03-19 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-29091), fixed in 2.1.14.
Get an email when WP Armour has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WP Armour (honeypot) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/honeypot (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/honeypot"><img src="https://laskyr.com/plugins/honeypot/badge.svg" alt="WP Armour vulnerability status"></a>