Skip to content
Laskyr

Plugins · highlighting-code-block · data as of 2026-11-04

Is Highlighting Code Block safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.2.1)

As of 2026-11-04. 1 issue is on record for older versions; version 2.2.1 or newer fixes all of them that state a fix.

Latest version
2.2.1
Last updated
2026-07-01
Active installs
10,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 5.6+

Add code block with syntax highlighting using prism.js. (Available for Gutenberg and Classic Editor) — by LOOS

What to do

  1. Update to the latest version (2.2.1). Anything older than 2.2.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get highlighting-code-block --field=version shows what you run; wp plugin update highlighting-code-block updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.4 CVE-2026-12108 · published 2026-07-10

Stored cross-site scripting (XSS) in Highlighting Code Block (2.2.0 and older)

Affected
2.2.0 and older
Fixed in
2.2.1 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Highlighting Code Block plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 2.2.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2026-12108Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Highlighting Code Block vulnerability status badge
<a href="https://laskyr.com/plugins/highlighting-code-block"><img src="https://laskyr.com/plugins/highlighting-code-block/badge.svg" alt="Highlighting Code Block vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit