Skip to content
Laskyr

Plugins · highlight-and-share · data as of 2026-11-04

Is Highlight and Share safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (6.1.0)

As of 2026-11-04. 2 issues are on record for older versions; version 5.3.0 or newer fixes all of them that state a fix.

Latest version
6.1.0
Last updated
2026-10-09
Active installs
700+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

A lightweight social sharing plugin for showing social networks when users highlight text, share images, headlines, or use Click to Share. — by BerryPress

What to do

  1. Update to the latest version (6.1.0). Anything older than 5.3.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get highlight-and-share --field=version shows what you run; wp plugin update highlight-and-share updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.7 CVE-2025-67586 · published 2025-12-09

Missing authorization check in Highlight and Share (5.2.0 and older)

Affected
5.2.0 and older
Fixed in
5.3.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Ronald Huereca Highlight and Share highlight-and-share allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Highlight and Share: from n/a through <= 5.2.0.

NVD CVE-2025-67586Patchstack advisory

medium 6.5 CVE-2025-58260 · published 2025-09-22

Stored cross-site scripting (XSS) in Highlight and Share (5.1.1 and older)

Affected
5.1.1 and older
Fixed in
5.2.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Ronald Huereca Highlight and Share highlight-and-share allows Stored XSS.This issue affects Highlight and Share: from n/a through <= 5.1.1.

NVD CVE-2025-58260Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Highlight and Share vulnerability status badge
<a href="https://laskyr.com/plugins/highlight-and-share"><img src="https://laskyr.com/plugins/highlight-and-share/badge.svg" alt="Highlight and Share vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit