Skip to content
Laskyr

Plugins · highland-software-custom-role-manager · data as of 2026-11-04

Is Highland Software Custom Role Manager safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.0.6)

As of 2026-11-04. 1 issue is on record for older versions; version 1.0.1 or newer fixes all of them that state a fix.

Latest version
1.0.6
Last updated
2026-11-04
Active installs
fewer than 10
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

Manage multiple user roles, create custom roles, and control capabilities with an intuitive role builder. — by jgrodgers

What to do

  1. Update to the latest version (1.0.6). Anything older than 1.0.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get highland-software-custom-role-manager --field=version shows what you run; wp plugin update highland-software-custom-role-manager updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-7106 · published 2026-04-27

Privilege escalation in Highland Software Custom Role Manager (1.0.0 and older)

Affected
1.0.0 and older
Fixed in
1.0.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Highland Software Custom Role Manager plugin for WordPress is vulnerable to Privilege Escalation in versions up to and including 1.0.0. This is due to insufficient authorization checks in the hscrm_save_user_roles() function, which is hooked to the personal_options_update action accessible by any authenticated user. This makes it possible for authenticated attackers, with Subscriber-level access or higher, to potentially modify user roles via the profile update form.

NVD CVE-2026-7106Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Highland Software Custom Role Manager vulnerability status badge
<a href="https://laskyr.com/plugins/highland-software-custom-role-manager"><img src="https://laskyr.com/plugins/highland-software-custom-role-manager/badge.svg" alt="Highland Software Custom Role Manager vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit