Skip to content
Laskyr

Plugins · helpfulcrowd-product-reviews · data as of 2026-11-04

Is Helpfulcrowd Product Reviews safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.0)

As of 2026-11-04. 1 issue is on record for older versions; version 1.3.0 or newer fixes all of them that state a fix.

Latest version
1.4.0
Last updated
2026-08-20
Active installs
50+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

HelpfulCrowd is a review marketing platform that collects, manages and displays video and photo reviews for your WooCommerce online shop and much more — by helpfulcrowd

What to do

  1. Update to the latest version (1.4.0). Anything older than 1.3.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get helpfulcrowd-product-reviews --field=version shows what you run; wp plugin update helpfulcrowd-product-reviews updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-8499 · published 2026-06-09

Security issue in Helpfulcrowd Product Reviews (1.2.9 and older)

Affected
1.2.9 and older
Fixed in
1.3.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Helpfulcrowd Product Reviews plugin for WordPress is vulnerable to Authorization Bypass via PHP Type Juggling in versions up to, and including, 1.2.9. This is due to the `helpfulcrowd_validate_token()` function using a loose comparison operator (`!=`) instead of a strict comparison (`!==`) when validating the `token` parameter, while the corresponding REST route `/wp-json/helpfulcrowd/v1/update-settings` is registered with a `permission_callback` of `__return_true`, making it reachable by unauthenticated users; submitting a JSON boolean `true` as the `token` value causes PHP's loose comparison to evaluate as equal to the non-empty base64-encoded secret string, bypassing the check entirely. This makes it possible for unauthenticated attackers to invoke `helpfulcrowd_settings_endpoint()` and write arbitrary attacker-controlled key-value pairs directly into the `helpfulcrowd_options` WordPress database option via `update_option()` without any sanitization or allowlist filtering, enabling full unauthenticated modification of the plugin's stored configuration.

NVD CVE-2026-8499Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Helpfulcrowd Product Reviews vulnerability status badge
<a href="https://laskyr.com/plugins/helpfulcrowd-product-reviews"><img src="https://laskyr.com/plugins/helpfulcrowd-product-reviews/badge.svg" alt="Helpfulcrowd Product Reviews vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit