Plugins · helpdesk-contact-form · data as of 2026-11-04
Is HelpDesk.com Contact Form safe? Known vulnerabilities and latest version
- Latest version
- 1.1.7
- Last updated
- 2026-07-27
- Active installs
- 20+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11 · PHP 6.1+
Use the WordPress contact form plugin by the HelpDesk.com ticket system to connect with visitors. Organize and manage messages — all without coding! — by HelpDesk.com
What to do
- Update to the latest version (1.1.7). Anything older than 1.1.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get helpdesk-contact-form --field=version shows what you run; wp plugin update helpdesk-contact-form updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2025-13657 · published 2026-01-07
Cross-site request forgery (CSRF) in HelpDesk.com Contact Form (1.1.5 and older)
- Affected
- 1.1.5 and older
- Fixed in
- 1.1.6 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The HelpDesk contact form plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.1.5. This is due to missing or incorrect nonce validation on the handle_query_args() function. This makes it possible for unauthenticated attackers to update the plugin's license ID and contact form ID settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
NVD CVE-2025-13657Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-07-27 — latest release on wordpress.org (1.1.7).
- 2026-01-07 — Cross-site request forgery (CSRF) disclosed (CVE-2025-13657), fixed in 1.1.6.
Get an email when HelpDesk.com Contact Form has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for HelpDesk.com Contact Form (helpdesk-contact-form) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/helpdesk-contact-form (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/helpdesk-contact-form"><img src="https://laskyr.com/plugins/helpdesk-contact-form/badge.svg" alt="HelpDesk.com Contact Form vulnerability status"></a>