Plugins · helloprint · data as of 2026-11-04
Is Plug your WooCommerce into the largest catalog… safe? Known vulnerabilities and latest version
- Status
- Closed 2025-12-04
- Known issues on record
- 5
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate helloprint && wp plugin delete helloprint
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 5 record(s) do not state which versions are affected.
medium 5.3 CVE-2025-13666 · published 2025-12-06
Missing authorization check in Plug your WooCommerce into the largest catalog… (2.1.2 and older)
- Affected
- 2.1.2 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Helloprint plugin for WordPress is vulnerable to Missing Authorization in versions up to, and including, 2.1.2. This is due to the plugin registering a public REST API endpoint without implementing authorization checks to verify request authenticity. This makes it possible for unauthenticated attackers to arbitrarily modify WooCommerce order statuses via the /wp-json/helloprint/v1/complete_order_from_helloprint_callback endpoint by providing a valid order reference ID.
high 7.7 CVE-2025-26540 · published 2025-03-03
Path traversal / file read in Plug your WooCommerce into the largest catalog… (2.0.7 and older)
- Affected
- 2.0.7 and older
- Fixed in
- 2.1.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in helloprint Helloprint helloprint allows Path Traversal.This issue affects Helloprint: from n/a through <= 2.0.7.
high 8.6 CVE-2025-26534 · published 2025-03-03
Path traversal / file read in Plug your WooCommerce into the largest catalog… (2.0.7 and older)
- Affected
- 2.0.7 and older
- Fixed in
- 2.1.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in helloprint Helloprint helloprint allows Path Traversal.This issue affects Helloprint: from n/a through <= 2.0.7.
critical 9.8 CVE-2024-50525 · published 2024-11-04
Arbitrary file upload in Plug your WooCommerce into the largest catalog… (2.0.4 and older)
- Affected
- 2.0.4 and older
- Fixed in
- 2.0.5
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Unrestricted Upload of File with Dangerous Type vulnerability in helloprint Helloprint helloprint allows Upload a Web Shell to a Web Server.This issue affects Helloprint: from n/a through <= 2.0.4.
medium 6.1 CVE-2022-3908 · published 2022-12-12
Reflected cross-site scripting (XSS) in Plug your WooCommerce into the largest catalog… (older than 1.4.7)
- Affected
- older than 1.4.7
- Fixed in
- 1.4.7
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Helloprint WordPress plugin before 1.4.7 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting
Recent activity
- 2025-12-04 — closed on wordpress.org (Security Issue).
- 2025-12-06 — Missing authorization check disclosed (CVE-2025-13666), fix version not stated.
- 2025-03-03 — Path traversal / file read disclosed (CVE-2025-26540), fixed in 2.1.0.
- 2025-03-03 — Path traversal / file read disclosed (CVE-2025-26534), fixed in 2.1.0.
Get an email when Plug your WooCommerce into the largest catalog… has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Plug your WooCommerce into the largest catalog… (helloprint) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Path traversal and file read (2) · Missing authorization (1) · Arbitrary file upload (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/helloprint (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/helloprint"><img src="https://laskyr.com/plugins/helloprint/badge.svg" alt="Plug your WooCommerce into the largest catalog… vulnerability status"></a>