Skip to content
Laskyr

Plugins · headless-single-sign-on · data as of 2026-11-04

Is Headless SSO Plugin for WP safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.7.1)

As of 2026-11-04. 3 issues are on record for older versions; version 1.7.1 or newer fixes all of them that state a fix.

Latest version
1.7.1
Last updated
2026-09-07
Active installs
10+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.7.2+

Headless SSO Plugin allows SSO login into any frontend application React, Flutter, Angular, Gatsby, etc via WordPress and Identity Providers. — by miniOrange

What to do

  1. Update to the latest version (1.7.1). Anything older than 1.7.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get headless-single-sign-on --field=version shows what you run; wp plugin update headless-single-sign-on updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.8 CVE-2026-62108 · published 2026-09-17

Security issue in Headless SSO Plugin for WP (1.7.0 and older)

Affected
1.7.0 and older
Fixed in
1.7.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Broken Authentication in Headless Single Sign On <= 1.7.0 versions.

NVD CVE-2026-62108Patchstack advisory

critical 9.8 CVE-2026-28149 · published 2026-08-13

PHP object injection in Headless SSO Plugin for WP (1.6 and older)

Affected
1.6 and older
Fixed in
1.6.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated PHP Object Injection in Headless Single Sign On <= 1.6 versions.

NVD CVE-2026-28149Patchstack advisory

critical 9.8 CVE-2026-28148 · published 2026-08-13

Security issue in Headless SSO Plugin for WP (1.6 and older)

Affected
1.6 and older
Fixed in
1.6.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Bypass Vulnerability in Headless Single Sign On <= 1.6 versions.

NVD CVE-2026-28148Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Headless SSO Plugin for WP vulnerability status badge
<a href="https://laskyr.com/plugins/headless-single-sign-on"><img src="https://laskyr.com/plugins/headless-single-sign-on/badge.svg" alt="Headless SSO Plugin for WP vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit