Skip to content
Laskyr

Plugins · header-and-footer-scripts · data as of 2026-11-04

Is Header and Footer Scripts safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.4.2)

As of 2026-11-04. 1 issue is on record for older versions; version 2.4.1 or newer fixes all of them that state a fix.

Latest version
2.4.2
Last updated
2026-02-01
Active installs
200,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 5.6+

Header and Footer Scripts plugin allows you to add scripts to WordPress site's and just before closing tag. — by Anand Kumar

What to do

  1. Update to the latest version (2.4.2). Anything older than 2.4.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get header-and-footer-scripts --field=version shows what you run; wp plugin update header-and-footer-scripts updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2025-11453 · published 2026-01-09

Stored cross-site scripting (XSS) in Header and Footer Scripts (2.3.0 and older)

Affected
2.3.0 and older
Fixed in
2.4.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Header and Footer Scripts plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the _inpost_head_script parameter in all versions up to, and including, 2.3.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-11453Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Header and Footer Scripts vulnerability status badge
<a href="https://laskyr.com/plugins/header-and-footer-scripts"><img src="https://laskyr.com/plugins/header-and-footer-scripts/badge.svg" alt="Header and Footer Scripts vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit