Skip to content
Laskyr

Plugins · header-and-footer-script-adder · data as of 2026-11-04

Is Header Footer Script Adder safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.1.1)

As of 2026-11-04. 2 issues are on record for older versions; version 2.1.1 or newer fixes all of them that state a fix.

Latest version
2.1.1
Last updated
2026-07-17
Active installs
1,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

Easily insert custom HTML, CSS, and JavaScript into your WordPress site's header, body, and footer without modifying theme files. — by mahethekiller

What to do

  1. Update to the latest version (2.1.1). Anything older than 2.1.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get header-and-footer-script-adder --field=version shows what you run; wp plugin update header-and-footer-script-adder updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-15394 · published 2026-07-23

Stored cross-site scripting (XSS) in Header Footer Script Adder (2.1 and older)

Affected
2.1 and older
Fixed in
2.1.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Header Footer Script Adder – Insert Code in Header, Body & Footer plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'asm_code' Snippet Meta in all versions up to, and including, 2.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-15394Wordfence advisoryCode change (fix)Plugin source

medium 6.4 CVE-2025-12109 · published 2025-12-13

Stored cross-site scripting (XSS) in Header Footer Script Adder (2.0.5 and older)

Affected
2.0.5 and older
Fixed in
2.0.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Header Footer Script Adder – Insert Code in Header, Body & Footer plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the script adder present in posts in all versions up to, and including, 2.0.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-12109Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Header Footer Script Adder vulnerability status badge
<a href="https://laskyr.com/plugins/header-and-footer-script-adder"><img src="https://laskyr.com/plugins/header-and-footer-script-adder/badge.svg" alt="Header Footer Script Adder vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit