Skip to content
Laskyr

Plugins · hd-quiz · data as of 2026-11-04

Is HD Quiz safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.2.3)

As of 2026-11-04. 5 issues are on record for older versions; version 2.2.2 or newer fixes all of them that state a fix.

Latest version
2.2.3
Last updated
2026-09-28
Active installs
6,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Create a Quiz. An easy-to-use feature rich plugin to create quizzes with quiz timer, pagination, hints, advanced marking, and leading help and support — by Harmonic Design

What to do

  1. Update to the latest version (2.2.3). Anything older than 2.2.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get hd-quiz --field=version shows what you run; wp plugin update hd-quiz updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-13422 · published 2026-06-27

Cross-site request forgery (CSRF) in HD Quiz (2.2.0 to 2.2.1)

Affected
2.2.0 to 2.2.1
Fixed in
2.2.2 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The HD Quiz plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions 2.2.0 to 2.2.1. This is due to missing or incorrect nonce validation on the hdq_validate_nonce function. This makes it possible for unauthenticated attackers to delete or modify quizzes and questions, create new quizzes, and change plugin settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2026-13422Wordfence advisoryPlugin source

medium 4.3 CVE-2026-24544 · published 2026-01-23

Missing authorization check in HD Quiz (2.0.9 and older)

Affected
2.0.9 and older
Fixed in
2.0.10
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Harmonic Design HD Quiz hd-quiz allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects HD Quiz: from n/a through <= 2.0.9.

NVD CVE-2026-24544Patchstack advisory

medium 4.8 CVE-2024-13383 · published 2025-05-15

Stored cross-site scripting (XSS) in HD Quiz (older than 2.0.0)

Affected
older than 2.0.0
Fixed in
2.0.0
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The HD Quiz WordPress plugin before 2.0.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

NVD CVE-2024-13383WPScan advisory

medium 4.8 CVE-2024-22161 · published 2024-01-31

Stored cross-site scripting (XSS) in HD Quiz (1.8.11 and older)

Affected
1.8.11 and older
Fixed in
1.8.12
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Harmonic Design HD Quiz allows Stored XSS.This issue affects HD Quiz: from n/a through 1.8.11.

NVD CVE-2024-22161Patchstack advisory

medium 5.4 CVE-2021-24571 · published 2021-08-23

Stored cross-site scripting (XSS) in HD Quiz (older than 1.8.4)

Affected
older than 1.8.4
Fixed in
1.8.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The HD Quiz WordPress plugin before 1.8.4 does not escape some of its Answers before outputting them in attribute when generating the Quiz, which could lead to Stored Cross-Site Scripting issues

NVD CVE-2021-24571WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
HD Quiz vulnerability status badge
<a href="https://laskyr.com/plugins/hd-quiz"><img src="https://laskyr.com/plugins/hd-quiz/badge.svg" alt="HD Quiz vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit