Plugins · hcaptcha-for-forms-and-more · data as of 2026-11-04
Is hCaptcha for WP safe? Known vulnerabilities and latest version
- Latest version
- 5.5.0
- Last updated
- 2026-10-30
- Active installs
- 70,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
The strongest CAPTCHA. Switch from reCAPTCHA and Turnstile for free. Works with 60+ integrations: Contact Form 7, Elementor, WooCommerce, Divi, etc. — by hcaptcha
What to do
- Update to the latest version (5.5.0). Anything older than 5.4.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get hcaptcha-for-forms-and-more --field=version shows what you run; wp plugin update hcaptcha-for-forms-and-more updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-103347 · published 2026-10-01
Security issue in hCaptcha for WP (5.3.0 and older)
- Affected
- 5.3.0 and older
- Fixed in
- 5.4.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Bypass Vulnerability in hCaptcha for WP <= 5.3.0 versions.
medium 5.3 CVE-2026-25315 · published 2026-02-19
Missing authorization check in hCaptcha for WP (4.21.1 and older)
- Affected
- 4.21.1 and older
- Fixed in
- 4.22.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in hcaptcha hCaptcha for WP hcaptcha-for-forms-and-more allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects hCaptcha for WP: from n/a through <= 4.21.1.
medium 6.4 CVE-2024-4014 · published 2024-04-20
Stored cross-site scripting (XSS) in hCaptcha for WP (4.0.0 and older)
- Affected
- 4.0.0 and older
- Fixed in
- 4.0.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The hCaptcha for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's cf7-hcaptcha shortcode in all versions up to, and including, 4.0.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recent activity
- 2026-10-30 — latest release on wordpress.org (5.5.0).
- 2026-10-01 — Security issue disclosed (CVE-2026-103347), fixed in 5.4.0.
- 2026-02-19 — Missing authorization check disclosed (CVE-2026-25315), fixed in 4.22.0.
- 2024-04-20 — Stored cross-site scripting (XSS) disclosed (CVE-2024-4014), fixed in 4.0.1.
Get an email when hCaptcha for WP has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for hCaptcha for WP (hcaptcha-for-forms-and-more) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/hcaptcha-for-forms-and-more (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/hcaptcha-for-forms-and-more"><img src="https://laskyr.com/plugins/hcaptcha-for-forms-and-more/badge.svg" alt="hCaptcha for WP vulnerability status"></a>