Skip to content
Laskyr

Plugins · hashthemes-demo-importer · data as of 2026-11-04

Is HashThemes Demo Importer safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.1.1)

As of 2026-11-04. 2 issues are on record for older versions; version 1.4.3 or newer fixes all of them that state a fix.

Latest version
2.1.1
Last updated
2026-10-02
Active installs
6,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

Transforming website setups from headache to 'click, click, done! — by hashthemes

What to do

  1. Update to the latest version (2.1.1). Anything older than 1.4.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get hashthemes-demo-importer --field=version shows what you run; wp plugin update hashthemes-demo-importer updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.9 CVE-2026-65483 · published 2026-07-23

Cross-site scripting (XSS) in HashThemes Demo Importer (1.4.2 and older)

Affected
1.4.2 and older
Fixed in
1.4.3 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Author Cross Site Scripting (XSS) in HashThemes Demo Importer <= 1.4.2 versions.

NVD CVE-2026-65483Patchstack advisory

high 8.1 CVE-2021-39333 · published 2021-11-01

Missing authorization check in HashThemes Demo Importer (1.1.1 to 1.1.1)

Affected
1.1.1 to 1.1.1
Fixed in
1.1.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Hashthemes Demo Importer Plugin <= 1.1.1 for WordPress contained several AJAX functions which relied on a nonce which was visible to all logged-in users for access control, allowing them to execute a function that truncated nearly all database tables and removed the contents of wp-content/uploads.

NVD CVE-2021-39333Wordfence advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
HashThemes Demo Importer vulnerability status badge
<a href="https://laskyr.com/plugins/hashthemes-demo-importer"><img src="https://laskyr.com/plugins/hashthemes-demo-importer/badge.svg" alt="HashThemes Demo Importer vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit