Skip to content
Laskyr

Plugins · hashbar-wp-notification-bar · data as of 2026-11-04

Is HashBar safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0.6)

As of 2026-11-04. 3 issues are on record for older versions; version 2.0.4 or newer fixes all of them that state a fix.

Latest version
2.0.6
Last updated
2026-10-28
Active installs
9,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4

Create Announcement Bars, Notification Bars & Popup Campaigns with countdown timers, A/B testing, smart targeting & analytics. — by DevItems

What to do

  1. Update to the latest version (2.0.6). Anything older than 2.0.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get hashbar-wp-notification-bar --field=version shows what you run; wp plugin update hashbar-wp-notification-bar updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.6 CVE-2026-94117 · published 2026-09-22

SQL injection in HashBar (2.0.3 and older)

Affected
2.0.3 and older
Fixed in
2.0.4
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in DevItems HashBar – WordPress Notification Bar allows Blind SQL Injection. This issue affects HashBar – WordPress Notification Bar: from n/a through 2.0.3.

NVD CVE-2026-94117Patchstack advisory

high 8.8 CVE-2026-66602 · published 2026-08-18

Cross-site request forgery (CSRF) in HashBar (2.0.0 and older)

Affected
2.0.0 and older
Fixed in
2.0.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in DevItems HashBar – WordPress Notification Bar allows Cross Site Request Forgery. This issue affects HashBar – WordPress Notification Bar: from n/a through 2.0.0.

NVD CVE-2026-66602Patchstack advisory

medium 4.8 CVE-2023-51372 · published 2023-12-29

Stored cross-site scripting (XSS) in HashBar (1.4.1 and older)

Affected
1.4.1 and older
Fixed in
1.4.2
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in HasThemes HashBar – WordPress Notification Bar allows Stored XSS.This issue affects HashBar – WordPress Notification Bar: from n/a through 1.4.1.

NVD CVE-2023-51372Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
HashBar vulnerability status badge
<a href="https://laskyr.com/plugins/hashbar-wp-notification-bar"><img src="https://laskyr.com/plugins/hashbar-wp-notification-bar/badge.svg" alt="HashBar vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit