Skip to content
Laskyr

Plugins · hash-form · data as of 2026-11-04

Is Hash Form safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.7)

As of 2026-11-04. 8 issues are on record for older versions; version 1.4.3 or newer fixes all of them that state a fix.

Latest version
1.4.7
Last updated
2026-10-21
Active installs
3,000+
Known issues on record
8
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

Create any kind of forms effortlessly with Hash Form – the ultimate drag & drop form builder plugin for WordPress. — by hashthemes

What to do

  1. Update to the latest version (1.4.7). Anything older than 1.4.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get hash-form --field=version shows what you run; wp plugin update hash-form updates it.

Check your version

Known vulnerabilities

8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 10.0 CVE-2026-81780 · published 2026-08-31

Arbitrary file upload in Hash Form (1.4.2 and older)

Affected
1.4.2 and older
Fixed in
1.4.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Arbitrary File Upload in Hash Form <= 1.4.2 versions.

NVD CVE-2026-81780Patchstack advisory

critical 9.8 CVE-2026-78292 · published 2026-08-27

PHP object injection in Hash Form (1.4.1 and older)

Affected
1.4.1 and older
Fixed in
1.4.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated PHP Object Injection in Hash Form <= 1.4.1 versions.

NVD CVE-2026-78292Patchstack advisory

medium 4.3 CVE-2026-78280 · published 2026-08-24

Cross-site request forgery (CSRF) in Hash Form (1.4.0 and older)

Affected
1.4.0 and older
Fixed in
1.4.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Request Forgery (CSRF) in Hash Form <= 1.4.0 versions.

NVD CVE-2026-78280Patchstack advisory

medium 4.3 CVE-2025-47468 · published 2025-05-07

Cross-site request forgery (CSRF) in Hash Form (1.2.8 and older)

Affected
1.2.8 and older
Fixed in
1.2.9
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in hashthemes Hash Form hash-form allows Cross Site Request Forgery.This issue affects Hash Form: from n/a through <= 1.2.8.

NVD CVE-2025-47468Patchstack advisory

medium 4.3 CVE-2024-12201 · published 2024-12-12

Missing authorization check in Hash Form (1.2.1 and older)

Affected
1.2.1 and older
Fixed in
1.2.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Hash Form – Drag & Drop Form Builder plugin for WordPress is vulnerable to unauthorized access due to a missing capability check when creating form styles in all versions up to, and including, 1.2.1. This makes it possible for authenticated attackers, with Contributor-level access and above, to create new form styles.

NVD CVE-2024-12201Wordfence advisoryCode change (fix)

medium 6.1 CVE-2024-9417 · published 2024-10-05

Cross-site scripting (XSS) in Hash Form (1.1.9 and older)

Affected
1.1.9 and older
Fixed in
1.2.0 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Hash Form – Drag & Drop Form Builder plugin for WordPress is vulnerable to limited file uploads due to a misconfigured file type validation in the 'handleUpload' function in all versions up to, and including, 1.1.9. This makes it possible for unauthenticated attackers to upload files that are excluded from both the 'allowedExtensions' and 'unallowed_extensions' arrays on the affected site's server, including files that may contain cross-site scripting.

NVD CVE-2024-9417Wordfence advisoryCode change (fix)Plugin source

critical 9.8 CVE-2024-5085 · published 2024-05-23

PHP object injection in Hash Form (1.1.0 and older)

Affected
1.1.0 and older
Fixed in
1.1.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Hash Form – Drag & Drop Form Builder plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 1.1.0 via deserialization of untrusted input in the 'process_entry' function. This makes it possible for unauthenticated attackers to inject a PHP Object. No known POP chain is present in the vulnerable software. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.

NVD CVE-2024-5085Wordfence advisoryCode change (fix)Plugin source

critical 9.8 CVE-2024-5084 · published 2024-05-23

Arbitrary file upload in Hash Form (1.1.0 and older)

Affected
1.1.0 and older
Fixed in
1.1.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Hash Form – Drag & Drop Form Builder plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the 'file_upload_action' function in all versions up to, and including, 1.1.0. This makes it possible for unauthenticated attackers to upload arbitrary files on the affected site's server which may make remote code execution possible.

NVD CVE-2024-5084Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Hash Form vulnerability status badge
<a href="https://laskyr.com/plugins/hash-form"><img src="https://laskyr.com/plugins/hash-form/badge.svg" alt="Hash Form vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit