Skip to content
Laskyr

Plugins · hash-elements · data as of 2026-11-04

Is Hash Elements safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.5.8)

As of 2026-11-04. 5 issues are on record for older versions; version 1.5.5 or newer fixes all of them that state a fix.

Latest version
1.5.8
Last updated
2026-10-27
Active installs
5,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

Hash Elements provides additional capability with 30+ elementor blocks to build your website. — by hashthemes

What to do

  1. Update to the latest version (1.5.8). Anything older than 1.5.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get hash-elements --field=version shows what you run; wp plugin update hash-elements updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-24618 · published 2026-06-12

Information disclosure in Hash Elements (1.5.4 and older)

Affected
1.5.4 and older
Fixed in
1.5.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in HashThemes Hash Elements allows Retrieve Embedded Sensitive Data. This issue affects Hash Elements: from n/a through 1.5.4.

NVD CVE-2026-24618Patchstack advisory

medium 6.5 CVE-2025-22296 · published 2025-01-07

Cross-site scripting (XSS) in Hash Elements (1.5.0 and older)

Affected
1.5.0 and older
Fixed in
1.5.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in hashthemes Hash Elements hash-elements.This issue affects Hash Elements: from n/a through <= 1.5.0.

NVD CVE-2025-22296Patchstack advisory

medium 5.3 CVE-2024-10802 · published 2024-11-13

Missing authorization check in Hash Elements (1.4.7 and older)

Affected
1.4.7 and older
Fixed in
1.4.8 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Hash Elements plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the hash_elements_get_posts_title_by_id() function in all versions up to, and including, 1.4.7. This makes it possible for unauthenticated attackers to retrieve draft post titles that should not be accessible to unauthenticated users.

NVD CVE-2024-10802Wordfence advisoryCode change (fix)

medium 5.4 CVE-2024-5177 · published 2024-05-23

Stored cross-site scripting (XSS) in Hash Elements (1.3.8 and older)

Affected
1.3.8 and older
Fixed in
1.3.9 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Hash Elements plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'url' parameter within multiple widgets in all versions up to, and including, 1.3.8 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-5177Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2024-30426 · published 2024-03-29

Stored cross-site scripting (XSS) in Hash Elements (1.3.3 and older)

Affected
1.3.3 and older
Fixed in
1.3.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in HashThemes Hash Elements allows Stored XSS.This issue affects Hash Elements: from n/a through 1.3.3.

NVD CVE-2024-30426Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Hash Elements vulnerability status badge
<a href="https://laskyr.com/plugins/hash-elements"><img src="https://laskyr.com/plugins/hash-elements/badge.svg" alt="Hash Elements vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit