Skip to content
Laskyr

Plugins · happyforms · data as of 2026-11-04

Is Happyforms safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.26.17)

As of 2026-11-04. 9 issues are on record for older versions; version 1.26.16 or newer fixes all of them that state a fix.

Latest version
1.26.17
Last updated
2026-10-05
Active installs
20,000+
Known issues on record
9
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Best WordPress contact form, newsletter form and payment form builder without the sucky stuff — lost emails, pesky spam, leaky privacy and outsourced … — by Happyforms

What to do

  1. Update to the latest version (1.26.17). Anything older than 1.26.16 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get happyforms --field=version shows what you run; wp plugin update happyforms updates it.

Check your version

Known vulnerabilities

9 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2026-14556 · published 2026-10-21

Security issue in Happyforms (older than 1.26.15)

Affected
older than 1.26.15
Fixed in
1.26.15
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by WPScan
Details from the advisory

The HappyForms WordPress plugin before 1.26.15 does not sanitise or escape a user-controlled referral value before embedding it in the form notification email, allowing unauthenticated attackers to inject arbitrary HTML into the emails site administrators receive.

NVD CVE-2026-14556WPScan advisory

high 7.1 CVE-2026-97065 · published 2026-09-30

Cross-site scripting (XSS) in Happyforms (1.26.15 and older)

Affected
1.26.15 and older
Fixed in
1.26.16
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Happyforms <= 1.26.15 versions.

NVD CVE-2026-97065Patchstack advisory

medium 6.6 CVE-2025-11977 · published 2026-07-10

File inclusion in Happyforms (1.26.12 and older)

Affected
1.26.12 and older
Fixed in
1.26.13 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Happyforms – Form Builder for WordPress: Drag & Drop Contact Forms, Surveys, Payments & Multipurpose Forms plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 1.26.12 via the happyforms_get_form_partial() function. This makes it possible for authenticated attackers, with Administrator-level access and above, to include and execute arbitrary .php files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where .php file types can be uploaded and included.

NVD CVE-2025-11977Wordfence advisoryCode change (fix)plugins.svn.wordpress.orgplugins.svn.wordpress.org

critical 9.8 CVE-2026-49768 · published 2026-06-15

PHP object injection in Happyforms (1.26.13 and older)

Affected
1.26.13 and older
Fixed in
1.26.14
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated PHP Object Injection in Happyforms <= 1.26.13 versions.

NVD CVE-2026-49768Patchstack advisory

medium 4.8 CVE-2024-10054 · published 2025-05-15

Stored cross-site scripting (XSS) in Happyforms (1.26.2 up to (not including) 1.26.3)

Affected
1.26.2 up to (not including) 1.26.3
Fixed in
1.26.3
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Happyforms WordPress plugin before 1.26.3 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

NVD CVE-2024-10054WPScan advisory

medium 5.4 CVE-2024-44063 · published 2024-09-15

Stored cross-site scripting (XSS) in Happyforms (1.26.0 and older)

Affected
1.26.0 and older
Fixed in
1.26.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Happyforms allows Stored XSS.This issue affects Happyforms: from n/a through 1.26.0.

NVD CVE-2024-44063Patchstack advisory

medium 5.3 CVE-2024-23521 · published 2024-06-11

Missing authorization check in Happyforms (1.25.10 and older)

Affected
1.25.10 and older
Fixed in
1.25.11
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Missing Authorization vulnerability in Happyforms.This issue affects Happyforms: from n/a through 1.25.10.

NVD CVE-2024-23521Patchstack advisory

medium 6.1 CVE-2023-48752 · published 2023-11-30

Reflected cross-site scripting (XSS) in Happyforms (1.25.9 and older)

Affected
1.25.9 and older
Fixed in
1.25.10 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Happyforms Form builder to get in touch with visitors, grow your email list and collect payments — Happyforms allows Reflected XSS.This issue affects Form builder to get in touch with visitors, grow your email list and collect payments — Happyforms: from n/a through 1.25.9.

NVD CVE-2023-48752Patchstack advisory

medium 5.4 CVE-2023-0096 · published 2023-02-06

Stored cross-site scripting (XSS) in Happyforms (older than 1.22.0)

Affected
older than 1.22.0
Fixed in
1.22.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Happyforms WordPress plugin before 1.22.0 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.

NVD CVE-2023-0096WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Happyforms vulnerability status badge
<a href="https://laskyr.com/plugins/happyforms"><img src="https://laskyr.com/plugins/happyforms/badge.svg" alt="Happyforms vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit