Plugins · handl-utm-grabber · data as of 2026-11-04
Is HandL UTM Grabber / Tracker safe? Known vulnerabilities and latest version
- Latest version
- 2.9.18
- Last updated
- 2026-10-27
- Active installs
- 10,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.4+
The WordPress attribution plugin used by over 250,000+ sites to capture UTMs, gclid, and source data in your forms, CRM, and revenue workflows. — by Haktan Suren
What to do
- Update to the latest version (2.9.18). Anything older than 2.9.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get handl-utm-grabber --field=version shows what you run; wp plugin update handl-utm-grabber updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-57351 · published 2026-07-02
Cross-site scripting (XSS) in HandL UTM Grabber / Tracker (2.9.2 and older)
- Affected
- 2.9.2 and older
- Fixed in
- 2.9.3
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in HandL UTM Grabber <= 2.9.2 versions.
high 7.1 CVE-2025-13072 · published 2025-12-10
Reflected cross-site scripting (XSS) in HandL UTM Grabber / Tracker (older than 2.8.1)
- Affected
- older than 2.8.1
- Fixed in
- 2.8.1
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The HandL UTM Grabber / Tracker WordPress plugin before 2.8.1 does not sanitize and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.
high 7.1 CVE-2025-13073 · published 2025-12-10
Reflected cross-site scripting (XSS) in HandL UTM Grabber / Tracker (older than 2.8.1)
- Affected
- older than 2.8.1
- Fixed in
- 2.8.1
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The HandL UTM Grabber / Tracker WordPress plugin before 2.8.1 does not sanitize and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
high 8.8 CVE-2019-15769 · published 2019-08-29
Cross-site request forgery (CSRF) in HandL UTM Grabber / Tracker (older than 2.6.5)
- Affected
- older than 2.6.5
- Fixed in
- 2.6.5
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The handl-utm-grabber plugin before 2.6.5 for WordPress has CSRF via add_option and update_option.
NVD CVE-2019-15769wordpress.orgwpvulndb.compluginvulnerabilities.com
Recent activity
- 2026-10-27 — latest release on wordpress.org (2.9.18).
- 2026-07-02 — Cross-site scripting (XSS) disclosed (CVE-2026-57351), fixed in 2.9.3.
- 2025-12-10 — Reflected cross-site scripting (XSS) disclosed (CVE-2025-13072), fixed in 2.8.1.
- 2025-12-10 — Reflected cross-site scripting (XSS) disclosed (CVE-2025-13073), fixed in 2.8.1.
Get an email when HandL UTM Grabber / Tracker has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for HandL UTM Grabber / Tracker (handl-utm-grabber) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/handl-utm-grabber (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/handl-utm-grabber"><img src="https://laskyr.com/plugins/handl-utm-grabber/badge.svg" alt="HandL UTM Grabber / Tracker vulnerability status"></a>