Skip to content
Laskyr

Plugins · h5pxapikatchu · data as of 2026-11-04

Is SNORDIAN's H5PxAPIkatchu safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (0.4.24)

As of 2026-11-04. 2 issues are on record for older versions; version 0.4.18 or newer fixes all of them that state a fix.

Latest version
0.4.24
Last updated
2026-06-16
Active installs
500+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8

Simple solution to catch 'em all, those xAPI statements that have been sent by H5P content types. — by otacke

What to do

  1. Update to the latest version (0.4.24). Anything older than 0.4.18 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get h5pxapikatchu --field=version shows what you run; wp plugin update h5pxapikatchu updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2025-12904 · published 2025-11-14

Stored cross-site scripting (XSS) in SNORDIAN's H5PxAPIkatchu (0.4.17 and older)

Affected
0.4.17 and older
Fixed in
0.4.18 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The SNORDIAN's H5PxAPIkatchu plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'insert_data' AJAX endpoint in all versions up to, and including, 0.4.17 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-12904Wordfence advisoryCode change (fix)

medium 5.3 CVE-2025-30821 · published 2025-03-27

Missing authorization check in SNORDIAN's H5PxAPIkatchu (0.4.14 and older)

Affected
0.4.14 and older
Fixed in
0.4.15
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in otacke SNORDIAN's H5PxAPIkatchu h5pxapikatchu allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects SNORDIAN's H5PxAPIkatchu: from n/a through <= 0.4.14.

NVD CVE-2025-30821Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
SNORDIAN's H5PxAPIkatchu vulnerability status badge
<a href="https://laskyr.com/plugins/h5pxapikatchu"><img src="https://laskyr.com/plugins/h5pxapikatchu/badge.svg" alt="SNORDIAN's H5PxAPIkatchu vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit