Skip to content
Laskyr

Plugins · h5p · data as of 2026-11-04

Is Interactive Content safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.17.10)

As of 2026-11-04. 7 issues are on record for older versions; version 1.17.10 or newer fixes all of them that state a fix.

Latest version
1.17.10
Last updated
2026-10-20
Active installs
40,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.0.8

Create and add rich content to your website for free. Some examples of what you get with H5P are Interactive Video, Quizzes, Collage and Timeline. — by icc0rz

What to do

  1. Update to the latest version (1.17.10). Anything older than 1.17.10 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get h5p --field=version shows what you run; wp plugin update h5p updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-112867 · published 2026-10-22

Stored cross-site scripting (XSS) in Interactive Content (1.17.9 and older)

Affected
1.17.9 and older
Fixed in
1.17.10
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in H5P H5P h5p allows Stored XSS.This issue affects H5P: from n/a through 1.17.9.

NVD CVE-2026-112867Patchstack advisory

medium 4.3 CVE-2026-112868 · published 2026-10-21

Missing authorization check in Interactive Content (1.17.9 and older)

Affected
1.17.9 and older
Fixed in
1.17.10
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Authorization Bypass Through User-Controlled Key vulnerability in H5P H5P h5p allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects H5P: from n/a through 1.17.9.

NVD CVE-2026-112868Patchstack advisory

high 7.1 CVE-2026-57321 · published 2026-06-26

Arbitrary file deletion in Interactive Content (1.17.7 and older)

Affected
1.17.7 and older
Fixed in
1.17.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor Arbitrary File Deletion in H5P <= 1.17.7 versions.

NVD CVE-2026-57321Patchstack advisory

high 7.1 CVE-2026-56006 · published 2026-06-25

Cross-site scripting (XSS) in Interactive Content (1.17.6 and older)

Affected
1.17.6 and older
Fixed in
1.17.7
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in H5P <= 1.17.6 versions.

NVD CVE-2026-56006Patchstack advisory

medium 5.3 CVE-2025-68505 · published 2025-12-24

Missing authorization check in Interactive Content (1.16.1 and older)

Affected
1.16.1 and older
Fixed in
1.16.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in icc0rz H5P h5p allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects H5P: from n/a through <= 1.16.1.

NVD CVE-2025-68505Patchstack advisory

medium 6.5 CVE-2025-62951 · published 2025-10-27

Stored cross-site scripting (XSS) in Interactive Content (1.16.0 and older)

Affected
1.16.0 and older
Fixed in
1.16.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in icc0rz H5P h5p allows Stored XSS.This issue affects H5P: from n/a through <= 1.16.0.

NVD CVE-2025-62951Patchstack advisory

medium 5.4 CVE-2024-3111 · published 2024-06-27

Stored cross-site scripting (XSS) in Interactive Content (older than 1.15.8)

Affected
older than 1.15.8
Fixed in
1.15.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Interactive Content WordPress plugin before 1.15.8 does not validate uploads which could allow a Contributors and above to update malicious SVG files, leading to Stored Cross-Site Scripting issues

NVD CVE-2024-3111WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Interactive Content vulnerability status badge
<a href="https://laskyr.com/plugins/h5p"><img src="https://laskyr.com/plugins/h5p/badge.svg" alt="Interactive Content vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit