Skip to content
Laskyr

Plugins · gzseo · data as of 2026-11-04

Is GZSEO safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0.15)

As of 2026-11-04. 2 issues are on record for older versions; version 2.0.15 or newer fixes all of them that state a fix.

Latest version
2.0.15
Last updated
2026-09-29
Active installs
400+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

GZSEO is an SEO assistant plugin designed to make content updates easier for SEO professionals. — by سید محمدامین هاشمی

What to do

  1. Update to the latest version (2.0.15). Anything older than 2.0.15 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get gzseo --field=version shows what you run; wp plugin update gzseo updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-25437 · published 2026-03-25

Missing authorization check in GZSEO (2.0.14 and older)

Affected
2.0.14 and older
Fixed in
2.0.15 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in سید محمدامین هاشمی GZSEO gzseo allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects GZSEO: from n/a through <= 2.0.14.

NVD CVE-2026-25437Patchstack advisory

medium 6.4 CVE-2025-14941 · published 2026-01-24

Stored cross-site scripting (XSS) in GZSEO (2.0.11 and older)

Affected
2.0.11 and older
Fixed in
2.0.12 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The GZSEO plugin for WordPress is vulnerable to authorization bypass leading to Stored Cross-Site Scripting in all versions up to, and including, 2.0.11. This is due to missing capability checks on multiple AJAX handlers combined with insufficient input sanitization and output escaping on the embed_code parameter. This makes it possible for authenticated attackers, with contributor level access and above, to inject arbitrary content into any post on the site that will execute whenever a user accesses an injected page.

NVD CVE-2025-14941Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
GZSEO vulnerability status badge
<a href="https://laskyr.com/plugins/gzseo"><img src="https://laskyr.com/plugins/gzseo/badge.svg" alt="GZSEO vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit