Plugins · gwolle-gb · data as of 2026-11-04
Is Gwolle Guestbook safe? Known vulnerabilities and latest version
- Latest version
- 5.1.2
- Last updated
- 2026-10-14
- Active installs
- 20,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.0+
Gwolle Guestbook is the WordPress guestbook you've just been looking for. Beautiful and easy. — by Marcel Pol
What to do
- Update to the latest version (5.1.2). Anything older than 5.1.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get gwolle-gb --field=version shows what you run; wp plugin update gwolle-gb updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.1 CVE-2026-103481 · published 2026-10-16
Reflected cross-site scripting (XSS) in Gwolle Guestbook (5.1.1 and older)
- Affected
- 5.1.1 and older
- Fixed in
- 5.1.2 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Gwolle Guestbook plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'permalink' parameter in all versions up to, and including, 5.1.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
NVD CVE-2026-103481Wordfence advisorycodeberg.orgPlugin source
medium 6.1 CVE-2025-5807 · published 2025-07-10
Stored cross-site scripting (XSS) in Gwolle Guestbook (4.9.2 and older)
- Affected
- 4.9.2 and older
- Fixed in
- 4.9.3 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Gwolle Guestbook plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘gwolle_gb_content’ parameter in all versions up to, and including, 4.9.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
high 7.1 CVE-2025-24710 · published 2025-01-31
Reflected cross-site scripting (XSS) in Gwolle Guestbook (4.7.1 and older)
- Affected
- 4.7.1 and older
- Fixed in
- 4.7.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Marcel Pol Gwolle Guestbook gwolle-gb allows Reflected XSS.This issue affects Gwolle Guestbook: from n/a through <= 4.7.1.
medium 6.1 CVE-2021-24980 · published 2021-12-27
Reflected cross-site scripting (XSS) in Gwolle Guestbook (older than 4.2.0)
- Affected
- older than 4.2.0
- Fixed in
- 4.2.0
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
The Gwolle Guestbook WordPress plugin before 4.2.0 does not sanitise and escape the gwolle_gb_user_email parameter before outputting it back in an attribute, leading to a Reflected Cross-Site Scripting issue in an admin page
medium 6.1 CVE-2018-17884 · published 2018-10-02
Cross-site scripting (XSS) in Gwolle Guestbook (older than 2.5.4)
- Affected
- older than 2.5.4
- Fixed in
- 2.5.4
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
XSS exists in admin/gb-dashboard-widget.php in the Gwolle Guestbook (gwolle-gb) plugin before 2.5.4 for WordPress via the PATH_INFO to wp-admin/index.php
critical 9.0 CVE-2015-8351 · published 2017-09-11
File inclusion in Gwolle Guestbook (older than 1.5.4)
- Affected
- older than 1.5.4
- Fixed in
- 1.5.4
- Access needed (per CVSS)
- No login needed
- Range from
- advisory text · score by NVD
Details from the advisory
PHP remote file inclusion vulnerability in the Gwolle Guestbook plugin before 1.5.4 for WordPress, when allow_url_include is enabled, allows remote authenticated users to execute arbitrary PHP code via a URL in the abspath parameter to frontend/captcha/ajaxresponse.php. NOTE: this can also be leveraged to include and execute arbitrary local files via directory traversal sequences regardless of whether allow_url_include is enabled.
NVD CVE-2015-8351wordpress.orgpacketstormsecurity.comsecurityfocus.comexploit-db.comhtbridge.com
Recent activity
- 2026-10-14 — latest release on wordpress.org (5.1.2).
- 2026-10-16 — Reflected cross-site scripting (XSS) disclosed (CVE-2026-103481), fixed in 5.1.2.
- 2025-07-10 — Stored cross-site scripting (XSS) disclosed (CVE-2025-5807), fixed in 4.9.3.
- 2025-01-31 — Reflected cross-site scripting (XSS) disclosed (CVE-2025-24710), fixed in 4.7.2.
Get an email when Gwolle Guestbook has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Gwolle Guestbook (gwolle-gb) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (5) · File inclusion (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/gwolle-gb (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/gwolle-gb"><img src="https://laskyr.com/plugins/gwolle-gb/badge.svg" alt="Gwolle Guestbook vulnerability status"></a>