Plugins · gutenverse-news · data as of 2026-11-04
Is Gutenverse News safe? Known vulnerabilities and latest version
- Latest version
- 3.3.3
- Last updated
- 2026-09-08
- Active installs
- 800+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11 · PHP 7.4.30+
Build news websites, blog and magazine layouts with WordPress news blocks, post grids, post sliders, archive blocks, and a news ticker. — by Jegstudio
What to do
- Update to the latest version (3.3.3). Anything older than 3.3.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get gutenverse-news --field=version shows what you run; wp plugin update gutenverse-news updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 8.8 CVE-2026-85677 · published 2026-09-11
Cross-site scripting (XSS) in Gutenverse News (older than 3.3.3)
- Affected
- older than 3.3.3
- Fixed in
- 3.3.3
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Gutenverse News WordPress plugin before 3.3.3 does not restrict the extra HTML it adds to WordPress's allowed elements to the context it is meant for, applying the same relaxed list to every sanitisation context including untrusted comments, allowing unauthenticated users to store JavaScript that will execute in the browser of any administrator who reviews the comment queue, and of any visitor to the post once the comment is approved.
medium 6.5 CVE-2025-62090 · published 2025-12-09
Missing authorization check in Gutenverse News (3.0.2 and older)
- Affected
- 3.0.2 and older
- Fixed in
- 3.1.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Jegstudio Gutenverse News – Advanced News Magazine Blog Gutenberg Blocks Addons gutenverse-news allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Gutenverse News – Advanced News Magazine Blog Gutenberg Blocks Addons: from n/a through <= 3.0.2.
medium 5.4 CVE-2025-5234 · published 2025-06-19
Stored cross-site scripting (XSS) in Gutenverse News (1.0.4 and older)
- Affected
- 1.0.4 and older
- Fixed in
- 2.0.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Gutenverse News plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘elementId’ parameter in all versions up to, and including, 1.0.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2025-5234Wordfence advisoryCode change (fix)wordpress.orgPlugin source
Recent activity
- 2026-09-08 — latest release on wordpress.org (3.3.3).
- 2026-09-11 — Cross-site scripting (XSS) disclosed (CVE-2026-85677), fixed in 3.3.3.
- 2025-12-09 — Missing authorization check disclosed (CVE-2025-62090), fixed in 3.1.0.
- 2025-06-19 — Stored cross-site scripting (XSS) disclosed (CVE-2025-5234), fixed in 2.0.0.
Get an email when Gutenverse News has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Gutenverse News (gutenverse-news) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Jegstudio (4 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/gutenverse-news (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/gutenverse-news"><img src="https://laskyr.com/plugins/gutenverse-news/badge.svg" alt="Gutenverse News vulnerability status"></a>