Skip to content
Laskyr

Plugins · gutenverse-form · data as of 2026-11-04

Is Gutenverse Form safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.2.1)

As of 2026-11-04. 5 issues are on record for older versions; version 3.0.11 or newer fixes all of them that state a fix.

Latest version
3.2.1
Last updated
2026-10-30
Active installs
10,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Contact form builder for WordPress with visual form blocks, saved entries, notifications, dashboard overview, and booking forms. — by Jegstudio

What to do

  1. Update to the latest version (3.2.1). Anything older than 3.0.11 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get gutenverse-form --field=version shows what you run; wp plugin update gutenverse-form updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.8 CVE-2026-106469 · published 2026-10-14

Cross-site scripting (XSS) in Gutenverse Form (older than 3.0.11)

Affected
older than 3.0.11
Fixed in
3.0.11
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Gutenverse Form WordPress plugin before 3.0.11 does not sanitize SVG icon markup stored in its form blocks before it is decoded and inserted into the page in the browser, allowing authenticated users with Contributor-level access and above to store malicious SVG that executes JavaScript in the session of any user who views or previews the affected form, such as an administrator reviewing a pending post.

NVD CVE-2026-106469WPScan advisory

high 7.1 CVE-2026-56040 · published 2026-06-26

Cross-site scripting (XSS) in Gutenverse Form (2.4.7 and older)

Affected
2.4.7 and older
Fixed in
2.5.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Gutenverse Form <= 2.4.7 versions.

NVD CVE-2026-56040Patchstack advisory

medium 6.4 CVE-2025-14984 · published 2026-01-08

Stored cross-site scripting (XSS) in Gutenverse Form (2.3.2 and older)

Affected
2.3.2 and older
Fixed in
2.4.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Gutenverse Form plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG file upload in all versions up to, and including, 2.3.2. This is due to the plugin's framework component adding SVG to the allowed MIME types via the upload_mimes filter without implementing any sanitization of SVG file contents. This makes it possible for authenticated attackers, with Author-level access and above, to upload SVG files containing malicious JavaScript that executes when the file is viewed, leading to arbitrary JavaScript execution in victims' browsers.

NVD CVE-2025-14984Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2025-68511 · published 2025-12-24

Missing authorization check in Gutenverse Form (2.3.1 and older)

Affected
2.3.1 and older
Fixed in
2.3.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Jegstudio Gutenverse Form gutenverse-form allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Gutenverse Form: from n/a through <= 2.3.1.

NVD CVE-2025-68511Patchstack advisory

medium 6.5 CVE-2025-66079 · published 2025-11-21

Missing authorization check in Gutenverse Form (2.2.0 and older)

Affected
2.2.0 and older
Fixed in
2.3.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Jegstudio Gutenverse Form gutenverse-form allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Gutenverse Form: from n/a through <= 2.2.0.

NVD CVE-2025-66079Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Gutenverse Form vulnerability status badge
<a href="https://laskyr.com/plugins/gutenverse-form"><img src="https://laskyr.com/plugins/gutenverse-form/badge.svg" alt="Gutenverse Form vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit