Skip to content
Laskyr

Plugins · gutenverse-companion · data as of 2026-11-04

Is Gutenverse Companion safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.5.4)

As of 2026-11-04. 2 issues are on record for older versions; version 2.5.2 or newer fixes all of them that state a fix.

Latest version
2.5.4
Last updated
2026-10-27
Active installs
9,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Companion plugin for Gutenverse base themes — by Jegstudio

What to do

  1. Update to the latest version (2.5.4). Anything older than 2.5.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get gutenverse-companion --field=version shows what you run; wp plugin update gutenverse-companion updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-66704 · published 2026-08-13

Server-side request forgery (SSRF) in Gutenverse Companion (2.5.1 and older)

Affected
2.5.1 and older
Fixed in
2.5.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Server Side Request Forgery (SSRF) in Gutenverse Companion <= 2.5.1 versions.

NVD CVE-2026-66704Patchstack advisory

high 7.5 CVE-2026-54832 · published 2026-06-26

Missing authorization check in Gutenverse Companion (2.5.0 and older)

Affected
2.5.0 and older
Fixed in
2.5.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Broken Access Control in Gutenverse Companion <= 2.5.0 versions.

NVD CVE-2026-54832Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Gutenverse Companion vulnerability status badge
<a href="https://laskyr.com/plugins/gutenverse-companion"><img src="https://laskyr.com/plugins/gutenverse-companion/badge.svg" alt="Gutenverse Companion vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit