Plugins · gutenkit-blocks-addon · data as of 2026-11-04
Is GutenKit safe? Known vulnerabilities and latest version
- Latest version
- 2.5.5
- Last updated
- 2026-11-01
- Active installs
- 80,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
GutenKit – Ultimate no-code Gutenberg blocks to design stunning web pages and visually stunning posts in WordPress block editor. — by Ataur R
What to do
- Update to the latest version (2.5.5). Anything older than 2.4.13 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get gutenkit-blocks-addon --field=version shows what you run; wp plugin update gutenkit-blocks-addon updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-2573 · published 2026-09-03
Stored cross-site scripting (XSS) in GutenKit (2.4.4 and older)
- Affected
- 2.4.4 and older
- Fixed in
- 2.4.5 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The GutenKit – Page Builder Blocks, Patterns, and Templates for Gutenberg Block Editor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘postBodyCss’ parameter in all versions up to, and including, 2.4.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
medium 5.3 CVE-2026-15827 · published 2026-07-23
Missing authorization check in GutenKit (2.4.12 and older)
- Affected
- 2.4.12 and older
- Fixed in
- 2.4.13 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The GutenKit Blocks plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the /wp-json/gutenkit/v1/mailchimp/get/lists and /wp-json/gutenkit/v1/mailchimp/get/interests REST API endpoints in versions up to, and including, 2.4.12. Both endpoints are registered with permission_callback => '__return_true', and their callbacks read the site's stored Mailchimp API key from the gutenkit_settings_list option and proxy Mailchimp audience/list, merge-field, interest-category, interest-name, and subscriber-count metadata back to the caller with no login, nonce, or capability check. This makes it possible for unauthenticated attackers to retrieve private Mailchimp audience configuration information from any site that has configured the GutenKit Mailchimp integration.
NVD CVE-2026-15827Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2025-57900 · published 2025-09-22
Stored cross-site scripting (XSS) in GutenKit (2.4.2 and older)
- Affected
- 2.4.2 and older
- Fixed in
- 2.4.3
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Ataur R GutenKit gutenkit-blocks-addon allows Stored XSS.This issue affects GutenKit: from n/a through <= 2.4.2.
medium 5.4 CVE-2025-46253 · published 2025-04-22
Stored cross-site scripting (XSS) in GutenKit (2.2.2 and older)
- Affected
- 2.2.2 and older
- Fixed in
- 2.2.3
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Ataur R GutenKit gutenkit-blocks-addon allows Stored XSS.This issue affects GutenKit: from n/a through <= 2.2.2.
critical 9.8 CVE-2024-9234 · published 2024-10-11
Arbitrary file upload in GutenKit (2.1.0 and older)
- Affected
- 2.1.0 and older
- Fixed in
- 2.1.1 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The GutenKit – Page Builder Blocks, Patterns, and Templates for Gutenberg Block Editor plugin for WordPress is vulnerable to arbitrary file uploads due to a missing capability check on the install_and_activate_plugin_from_external() function (install-active-plugin REST API endpoint) in all versions up to, and including, 2.1.0. This makes it possible for unauthenticated attackers to install and activate arbitrary plugins, or utilize the functionality to upload arbitrary files spoofed like plugins.
Recent activity
- 2026-11-01 — latest release on wordpress.org (2.5.5).
- 2026-09-03 — Stored cross-site scripting (XSS) disclosed (CVE-2026-2573), fixed in 2.4.5.
- 2026-07-23 — Missing authorization check disclosed (CVE-2026-15827), fixed in 2.4.13.
- 2025-09-22 — Stored cross-site scripting (XSS) disclosed (CVE-2025-57900), fixed in 2.4.3.
Get an email when GutenKit has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for GutenKit (gutenkit-blocks-addon) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3) · Missing authorization (1) · Arbitrary file upload (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/gutenkit-blocks-addon (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/gutenkit-blocks-addon"><img src="https://laskyr.com/plugins/gutenkit-blocks-addon/badge.svg" alt="GutenKit vulnerability status"></a>