Skip to content
Laskyr

Plugins · gutenify · data as of 2026-11-04

Is Gutenify safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.9.0)

As of 2026-11-04. 5 issues are on record for older versions; version 1.6.0 or newer fixes all of them that state a fix.

Latest version
1.9.0
Last updated
2026-10-04
Active installs
5,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

Gutenify is a free WordPress plugin with 40+ Gutenberg blocks and ready-made starter templates for building your site visually, without code. — by CodeYatri

What to do

  1. Update to the latest version (1.9.0). Anything older than 1.6.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get gutenify --field=version shows what you run; wp plugin update gutenify updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2025-8605 · published 2025-11-18

Stored cross-site scripting (XSS) in Gutenify (1.5.9 and older)

Affected
1.5.9 and older
Fixed in
1.6.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Gutenify – Visual Site Builder Blocks & Site Templates. plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's block attributes in all versions up to, and including, 1.5.9 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-8605Wordfence advisorywordpress.org

high 7.1 CVE-2025-53324 · published 2025-11-06

Stored cross-site scripting (XSS) in Gutenify (1.5.7 and older)

Affected
1.5.7 and older
Fixed in
1.5.8
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CodeYatri Gutenify gutenify allows Stored XSS.This issue affects Gutenify: from n/a through <= 1.5.7.

NVD CVE-2025-53324Patchstack advisory

high 7.5 CVE-2025-53326 · published 2025-08-28

File inclusion in Gutenify (1.5.4 and older)

Affected
1.5.4 and older
Fixed in
1.5.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in CodeYatri Gutenify gutenify allows PHP Local File Inclusion.This issue affects Gutenify: from n/a through <= 1.5.4.

NVD CVE-2025-53326Patchstack advisory

medium 6.5 CVE-2025-32168 · published 2025-04-04

Stored cross-site scripting (XSS) in Gutenify (1.5.7 and older)

Affected
1.5.7 and older
Fixed in
1.5.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CodeYatri Gutenify gutenify allows Stored XSS.This issue affects Gutenify: from n/a through <= 1.5.7.

NVD CVE-2025-32168Patchstack advisory

medium 5.3 CVE-2024-35165 · published 2024-05-14

Information disclosure in Gutenify (1.4.0 and older)

Affected
1.4.0 and older
Fixed in
1.4.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Gutenify.This issue affects Gutenify: from n/a through 1.4.0.

NVD CVE-2024-35165Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Gutenify vulnerability status badge
<a href="https://laskyr.com/plugins/gutenify"><img src="https://laskyr.com/plugins/gutenify/badge.svg" alt="Gutenify vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit