Plugins · gutenberg · data as of 2026-11-01
Is Gutenberg safe? Known vulnerabilities and latest version
- Latest version
- 24.3.0
- Last updated
- 2026-10-28
- Active installs
- 400,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
The Gutenberg plugin adds editing, customization, and site building to WordPress. Use it to test beta features before their official release. — by WordPress.org
What to do
- Update to the latest version (24.3.0). Anything older than 21.9.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get gutenberg --field=version shows what you run; wp plugin update gutenberg updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2025-64354 · published 2025-10-31
Stored cross-site scripting (XSS) in Gutenberg (21.8.2 and older)
- Affected
- 21.8.2 and older
- Fixed in
- 21.9.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Matias Ventura Gutenberg gutenberg allows Stored XSS.This issue affects Gutenberg: from n/a through <= 21.8.2.
medium 6.5 CVE-2024-37492 · published 2024-07-21
Stored cross-site scripting (XSS) in Gutenberg (18.6.0 and older)
- Affected
- 18.6.0 and older
- Fixed in
- 18.6.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Gutenberg Team Gutenberg allows Stored XSS.This issue affects Gutenberg: from n/a through 18.6.0.
medium 5.4 CVE-2023-38000 · published 2023-10-13
Cross-site scripting (XSS) in Gutenberg (16.8.0 and older)
- Affected
- 16.8.0 and older
- Fixed in
- 16.8.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Auth. Stored (contributor+) Cross-Site Scripting (XSS) vulnerability in WordPress core 6.3 through 6.3.1, from 6.2 through 6.2.2, from 6.1 through 6.1.3, from 6.0 through 6.0.5, from 5.9 through 5.9.7 and Gutenberg plugin <= 16.8.0 versions.
NVD CVE-2023-38000Patchstack advisoryPatchstack advisoryPatchstack advisory
Recent activity
- 2026-10-28 — latest release on wordpress.org (24.3.0).
- 2025-10-31 — Stored cross-site scripting (XSS) disclosed (CVE-2025-64354), fixed in 21.9.0.
- 2024-07-21 — Stored cross-site scripting (XSS) disclosed (CVE-2024-37492), fixed in 18.6.1.
- 2023-10-13 — Cross-site scripting (XSS) disclosed (CVE-2023-38000), fixed in 16.8.1.
Get an email when Gutenberg has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Gutenberg (gutenberg) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/gutenberg (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/gutenberg"><img src="https://laskyr.com/plugins/gutenberg/badge.svg" alt="Gutenberg vulnerability status"></a>