Skip to content
Laskyr

Plugins · gutenbee · data as of 2026-11-04

Is GutenBee safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.20.5)

As of 2026-11-04. 2 issues are on record for older versions; version 2.20.2 or newer fixes all of them that state a fix.

Latest version
2.20.5
Last updated
2026-10-22
Active installs
6,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

GutenBee enhances the Gutenberg editor with more blocks! — by The CSSIgniter Team

What to do

  1. Update to the latest version (2.20.5). Anything older than 2.20.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get gutenbee --field=version shows what you run; wp plugin update gutenbee updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-9227 · published 2026-05-28

Arbitrary file upload in GutenBee (2.20.1 and older)

Affected
2.20.1 and older
Fixed in
2.20.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The GutenBee – Gutenberg Blocks plugin for WordPress is vulnerable to Arbitrary File Upload in all versions up to, and including, 2.20.1 via the gutenbee_file_and_ext_json function. This is due to a flawed strpos() substring check that only verifies whether the filename contains the string '.json' rather than confirming the filename ends with a .json extension, allowing double-extension filenames like shell.json.php to bypass validation. This makes it possible for authenticated attackers, with author-level access and above, to upload files that may be executable, which makes remote code execution possible.

NVD CVE-2026-9227Wordfence advisoryCode change (fix)github.comPlugin source

medium 6.4 CVE-2025-8566 · published 2025-09-30

Stored cross-site scripting (XSS) in GutenBee (2.18.0 and older)

Affected
2.18.0 and older
Fixed in
2.18.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The GutenBee – Gutenberg Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via parameters in the CountUp and Google Maps Blocks in all versions up to, and including, 2.18.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-8566Wordfence advisoryCode change (fix)wordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
GutenBee vulnerability status badge
<a href="https://laskyr.com/plugins/gutenbee"><img src="https://laskyr.com/plugins/gutenbee/badge.svg" alt="GutenBee vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit