Skip to content
Laskyr

Plugins · guest-support · data as of 2026-11-04

Is Guest Support safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.3.3)

As of 2026-11-04. 2 issues are on record for older versions; version 1.3.0 or newer fixes all of them that state a fix.

Latest version
1.3.3
Last updated
2026-09-23
Active installs
30+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Let customers create and reply to support tickets without an account or login. A WordPress customer support system and help desk for your website. — by RcaTheme.com

What to do

  1. Update to the latest version (1.3.3). Anything older than 1.3.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get guest-support --field=version shows what you run; wp plugin update guest-support updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2025-13660 · published 2025-12-12

Information disclosure in Guest Support (1.2.3 and older)

Affected
1.2.3 and older
Fixed in
1.3.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Guest Support plugin for WordPress is vulnerable to User Email Disclosure in versions up to, and including, 1.2.3. This is due to the plugin exposing a public AJAX endpoint that allows anyone to search for and retrieve user email addresses without any authentication or capability checks. This makes it possible for unauthenticated attackers to enumerate user accounts and extract email addresses via the guest_support_handler=ajax endpoint with the request=get_users parameter.

NVD CVE-2025-13660Wordfence advisoryCode change (fix)Plugin source

medium 5.3 CVE-2025-5957 · published 2025-07-08

Missing authorization check in Guest Support (1.2.2 and older)

Affected
1.2.2 and older
Fixed in
1.2.3 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Guest Support – Complete customer support ticket system for WordPress plugin for WordPress is vulnerable to unauthorized loss of data due to a missing capability check on the 'deleteMassTickets' function in all versions up to, and including, 1.2.2. This makes it possible for unauthenticated attackers to delete arbitrary support tickets.

NVD CVE-2025-5957Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Guest Support vulnerability status badge
<a href="https://laskyr.com/plugins/guest-support"><img src="https://laskyr.com/plugins/guest-support/badge.svg" alt="Guest Support vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit