Plugins · gtranslate · data as of 2026-11-01
Is Translate WordPress with GTranslate safe? Known vulnerabilities and latest version
- Latest version
- 5.0.2
- Last updated
- 2026-10-23
- Active installs
- 900,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
Translate WordPress with Google Translate multilanguage plugin using AI translation. Complete multilingual SEO solution, WooCommerce compatible. — by edo888
What to do
- Update to the latest version (5.0.2). Anything older than 3.0.10 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get gtranslate --field=version shows what you run; wp plugin update gtranslate updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 1 record(s) do not state which versions are affected.
low 3.5 CVE-2025-15695 · published 2026-09-11
Cross-site scripting (XSS) in Translate WordPress with GTranslate (older than 3.0.10)
- Affected
- older than 3.0.10
- Fixed in
- 3.0.10
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Translate WordPress with GTranslate WordPress plugin before 3.0.10 does not validate one of its settings before the bundled front-end scripts build markup from it, allowing users with a role as high as administrator to store JavaScript that runs in the session of any visitor to the site.
medium 4.8 CVE-2023-4502 · published 2023-09-25
Stored cross-site scripting (XSS) in Translate WordPress with GTranslate (older than 3.0.4)
- Affected
- older than 3.0.4
- Fixed in
- 3.0.4
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Translate WordPress with GTranslate WordPress plugin before 3.0.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup). This vulnerability affects multiple parameters.
high 8.8 CVE-2022-0770 · published 2022-03-28
Cross-site request forgery (CSRF) in Translate WordPress with GTranslate (older than 2.9.9)
- Affected
- older than 2.9.9
- Fixed in
- 2.9.9
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
The Translate WordPress with GTranslate WordPress plugin before 2.9.9 does not have CSRF check in some files, and write debug data such as user's cookies in a publicly accessible file if a specific parameter is used when requesting them. Combining those two issues, an attacker could gain access to a logged in admin cookies by making them open a malicious link or page
medium 4.7 CVE-2021-25103 · published 2022-02-07
Reflected cross-site scripting (XSS) in Translate WordPress with GTranslate (older than 2.9.7)
- Affected
- older than 2.9.7
- Fixed in
- 2.9.7
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
The Translate WordPress with GTranslate WordPress plugin before 2.9.7 does not sanitise and escape the body parameter in the url_addon/gtranslate-email.php file before outputting it back in the page, leading to a Reflected Cross-Site Scripting issue. Note: exploitation of the issue requires knowledge of the NONCE_SALT and NONCE_KEY
medium 6.1 CVE-2021-34630 · published 2021-07-30
Reflected cross-site scripting (XSS) in Translate WordPress with GTranslate (not stated by the source)
- Affected
- not stated by the source
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- not stated · score by NVD
Details from the advisory
In the Pro and Enterprise versions of GTranslate < 2.8.65, the gtranslate_request_uri_var function runs at the top of all pages and echoes out the contents of $_SERVER['REQUEST_URI']. Although this uses addslashes, and most modern browsers automatically URLencode requests, this plugin is still vulnerable to Reflected XSS in older browsers such as Internet Explorer 9 or below, or in cases where an attacker is able to modify the request en route between the client and the server, or in cases where the user is using an atypical browsing solution.
medium 6.1 CVE-2020-11930 · published 2020-04-20
Reflected cross-site scripting (XSS) in Translate WordPress with GTranslate (older than 2.8.52)
- Affected
- older than 2.8.52
- Fixed in
- 2.8.52
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
The GTranslate plugin before 2.8.52 for WordPress has Reflected XSS via a crafted link. This requires use of the hreflang tags feature within a sub-domain or sub-directory paid option.
NVD CVE-2020-11930Code change (fix)wordpress.orgwpvulndb.com
Recent activity
- 2026-10-23 — latest release on wordpress.org (5.0.2).
- 2026-09-11 — Cross-site scripting (XSS) disclosed (CVE-2025-15695), fixed in 3.0.10.
- 2023-09-25 — Stored cross-site scripting (XSS) disclosed (CVE-2023-4502), fixed in 3.0.4.
- 2022-03-28 — Cross-site request forgery (CSRF) disclosed (CVE-2022-0770), fixed in 2.9.9.
Get an email when Translate WordPress with GTranslate has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Translate WordPress with GTranslate (gtranslate) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/gtranslate (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/gtranslate"><img src="https://laskyr.com/plugins/gtranslate/badge.svg" alt="Translate WordPress with GTranslate vulnerability status"></a>