Plugins · gt3-photo-video-gallery · data as of 2026-11-04
Is Photo Gallery safe? Known vulnerabilities and latest version
- Latest version
- 2.7.7.32
- Last updated
- 2026-09-04
- Active installs
- 10,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.0+
GT3 Image Gallery - create photo gallery, video gallery, block gallery, slider and more with ease. All photo galleries are responsive and loading fast — by gt3themes
What to do
- Update to the latest version (2.7.7.32). Anything older than 2.7.7.30 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get gt3-photo-video-gallery --field=version shows what you run; wp plugin update gt3-photo-video-gallery updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-65519 · published 2026-07-23
Cross-site scripting (XSS) in Photo Gallery (2.7.7.29 and older)
- Affected
- 2.7.7.29 and older
- Fixed in
- 2.7.7.30
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Author Cross Site Scripting (XSS) in Photo Gallery <= 2.7.7.29 versions.
high 7.1 CVE-2025-69084 · published 2026-01-06
Reflected cross-site scripting (XSS) in Photo Gallery (2.7.7.26 and older)
- Affected
- 2.7.7.26 and older
- Fixed in
- 2.7.7.27
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in gt3themes Photo Gallery gt3-photo-video-gallery allows Reflected XSS.This issue affects Photo Gallery: from n/a through <= 2.7.7.26.
medium 6.5 CVE-2025-47677 · published 2025-05-07
Stored cross-site scripting (XSS) in Photo Gallery (2.7.7.25 and older)
- Affected
- 2.7.7.25 and older
- Fixed in
- 2.7.7.26
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in gt3themes Photo Gallery gt3-photo-video-gallery allows Stored XSS.This issue affects Photo Gallery: from n/a through <= 2.7.7.25.
high 7.1 CVE-2025-24707 · published 2025-02-03
Reflected cross-site scripting (XSS) in Photo Gallery (2.7.7.24 and older)
- Affected
- 2.7.7.24 and older
- Fixed in
- 2.7.7.25
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in gt3themes Photo Gallery gt3-photo-video-gallery allows Reflected XSS.This issue affects Photo Gallery: from n/a through <= 2.7.7.24.
medium 6.4 CVE-2024-4035 · published 2024-04-25
Stored cross-site scripting (XSS) in Photo Gallery (2.7.7.21 and older)
- Affected
- 2.7.7.21 and older
- Fixed in
- 2.7.7.23 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Photo Gallery – GT3 Image Gallery & Gutenberg Block Gallery plugin for WordPress is vulnerable to Stored Cross-Site Scripting via image alt text in all versions up to, and including, 2.7.7.21 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recent activity
- 2026-09-04 — latest release on wordpress.org (2.7.7.32).
- 2026-07-23 — Cross-site scripting (XSS) disclosed (CVE-2026-65519), fixed in 2.7.7.30.
- 2026-01-06 — Reflected cross-site scripting (XSS) disclosed (CVE-2025-69084), fixed in 2.7.7.27.
- 2025-05-07 — Stored cross-site scripting (XSS) disclosed (CVE-2025-47677), fixed in 2.7.7.26.
Get an email when Photo Gallery has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Photo Gallery (gt3-photo-video-gallery) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (5)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/gt3-photo-video-gallery (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/gt3-photo-video-gallery"><img src="https://laskyr.com/plugins/gt3-photo-video-gallery/badge.svg" alt="Photo Gallery vulnerability status"></a>