Skip to content
Laskyr

Plugins · gspeech · data as of 2026-11-04

Is GSpeech TTS safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.23.1)

As of 2026-11-04. 2 issues are on record for older versions; version 3.22.1 or newer fixes all of them that state a fix.

Latest version
3.23.1
Last updated
2026-10-13
Active installs
3,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

Free WordPress text to speech audio player for accessibility. Add audio to posts with OpenAI, Gemini and Google Cloud voices. No API keys. — by Creative-Solutions

What to do

  1. Update to the latest version (3.23.1). Anything older than 3.22.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get gspeech --field=version shows what you run; wp plugin update gspeech updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-96578 · published 2026-10-02

Stored cross-site scripting (XSS) in GSpeech TTS (3.22.0 and older)

Affected
3.22.0 and older
Fixed in
3.22.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The GSpeech TTS – WordPress Text To Speech Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Comment Content in all versions up to, and including, 3.22.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This mXSS-style transform bypasses WordPress comment kses sanitization because the payload is stored using only kses-allowed tags and attributes; the malicious event handlers and style fragments become active only when the plugin's output-buffer callback rewrites the rendered HTML at request time.

NVD CVE-2026-96578Wordfence advisoryCode change (fix)Plugin source

medium 4.9 CVE-2025-10187 · published 2025-10-18

SQL injection in GSpeech TTS (3.17.3 and older)

Affected
3.17.3 and older
Fixed in
3.17.4 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The GSpeech TTS – WordPress Text To Speech Plugin plugin for WordPress is vulnerable to SQL Injection via the 'field' parameter in all versions up to, and including, 3.17.13 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2025-10187Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
GSpeech TTS vulnerability status badge
<a href="https://laskyr.com/plugins/gspeech"><img src="https://laskyr.com/plugins/gspeech/badge.svg" alt="GSpeech TTS vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit